aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDerek Harland <derek.harland@finq.co.nz>2014-04-16 11:56:32 +1200
committerDerek Harland <derek.harland@finq.co.nz>2014-04-16 11:56:32 +1200
commitce40b6431110a8ecee5be95eb56df4d622a41943 (patch)
tree8c678fb0b9e3613537ac9c5235885973904196a9 /setup.py
parent71a3ea74ba27e172aa98a0e7ddef35464a143fe4 (diff)
downloadexternal_python_mako-ce40b6431110a8ecee5be95eb56df4d622a41943.tar.gz
external_python_mako-ce40b6431110a8ecee5be95eb56df4d622a41943.tar.bz2
external_python_mako-ce40b6431110a8ecee5be95eb56df4d622a41943.zip
Convert mako-render into module mako.cmd and add suitable entrypoint to setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 04d4551..55cf1c9 100644
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,6 @@ setup(name='Mako',
url='http://www.makotemplates.org/',
license='MIT',
packages=find_packages('.', exclude=['examples*', 'test*']),
- scripts=['scripts/mako-render'],
tests_require=['nose >= 0.11'],
test_suite="nose.collector",
zip_safe=False,
@@ -58,5 +57,8 @@ setup(name='Mako',
[babel.extractors]
mako = mako.ext.babelplugin:extract
+
+ [console_scripts]
+ mako-render = mako.cmd:cmdline
"""
)