aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2008-09-07 19:29:29 +0000
committerMike Bayer <mike_mp@zzzcomputing.com>2008-09-07 19:29:29 +0000
commitc9343d37cc919e7f6d8f0cb67fe88a6226a0c1f0 (patch)
treedf510442de5ad54e5793443d89c04f2dae92ffe1 /setup.py
parent17516bbbdd19ec9df11dcf7450243f0492ef58da (diff)
downloadexternal_python_mako-c9343d37cc919e7f6d8f0cb67fe88a6226a0c1f0.tar.gz
external_python_mako-c9343d37cc919e7f6d8f0cb67fe88a6226a0c1f0.tar.bz2
external_python_mako-c9343d37cc919e7f6d8f0cb67fe88a6226a0c1f0.zip
- fixed cache code to work with Beaker 1.0.1, which is now the required version of Beaker.
- removed unnecessary attributes from DefTemplate. - added ModuleTemplate class, which allows the construction of a Template given a Python module generated by a previous Template. This allows Python modules alone to be used as templates with no compilation step. Source code and template source are optional but allow error reporting to work correctly.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index eb42a22..5cd2558 100644
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,7 @@ SVN version:
scripts=['scripts/mako-render'],
zip_safe=False,
install_requires=[
- 'Beaker',
+ 'Beaker>=1.0.1',
],
entry_points="""
[python.templating.engines]