aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2016-03-10 16:54:46 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2016-03-10 16:55:45 -0500
commit48b04e6af840315cd593a061d6de303fb84c6784 (patch)
tree8a6a1dabbed9b71e69a5e01231321de641665404 /setup.py
parent5c27fdf7774ec205afedbb0bc22782c889f75add (diff)
downloadexternal_python_mako-48b04e6af840315cd593a061d6de303fb84c6784.tar.gz
external_python_mako-48b04e6af840315cd593a061d6de303fb84c6784.tar.bz2
external_python_mako-48b04e6af840315cd593a061d6de303fb84c6784.zip
- use py.test as default test runner
- upgrade tox file to use py35, coverage, etc. - add flake8 rules
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 25 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 56754aa..5b64d3f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
from setuptools import setup, find_packages
+from setuptools.command.test import test as TestCommand
import os
import re
import sys
@@ -13,8 +14,8 @@ if sys.version_info < (2, 6):
raise Exception("Mako requires Python 2.6 or higher.")
markupsafe_installs = (
- sys.version_info >= (2, 6) and sys.version_info < (3, 0)
- ) or sys.version_info >= (3, 3)
+ sys.version_info >= (2, 6) and sys.version_info < (3, 0)
+) or sys.version_info >= (3, 3)
install_requires = []
@@ -26,6 +27,26 @@ try:
except ImportError:
install_requires.append('argparse')
+
+class PyTest(TestCommand):
+ user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
+
+ def initialize_options(self):
+ TestCommand.initialize_options(self)
+ self.pytest_args = []
+
+ def finalize_options(self):
+ TestCommand.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+
+ def run_tests(self):
+ # import here, cause outside the eggs aren't loaded
+ import pytest
+ errno = pytest.main(self.pytest_args)
+ sys.exit(errno)
+
+
setup(name='Mako',
version=VERSION,
description="A super-fast templating language that borrows the \
@@ -47,8 +68,8 @@ setup(name='Mako',
url='http://www.makotemplates.org/',
license='MIT',
packages=find_packages('.', exclude=['examples*', 'test*']),
- tests_require=['nose >= 0.11', 'mock'],
- test_suite="nose.collector",
+ tests_require=['pytest', 'mock'],
+ cmdclass={'test': PyTest},
zip_safe=False,
install_requires=install_requires,
extras_require={},