summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Martins <bgcngm@gmail.com>2019-10-05 22:00:56 (GMT)
committerBruno Martins <bgcngm@gmail.com>2019-10-20 13:00:37 (GMT)
commit9db155928c59b32108a41918d44fa382cff99bd7 (patch)
tree0b331b3689f773e81bc82fe61841701d9028b876
parentd4c4dec44e74ce97172af602f3991ecef22c858f (diff)
downloadandroid_packages_apps_Trebuchet-9db155928c59b32108a41918d44fa382cff99bd7.zip
android_packages_apps_Trebuchet-9db155928c59b32108a41918d44fa382cff99bd7.tar.gz
android_packages_apps_Trebuchet-9db155928c59b32108a41918d44fa382cff99bd7.tar.bz2
Trebuchet: Bump min SDK to 26 as required for adaptive icons
Addresses the following compilation error: packages/apps/Trebuchet/res/mipmap-anydpi/ic_launcher.xml: error: <adaptive-icon> elements require a sdk version of at least 26. Change-Id: I5684e917ef0b691d99e2e59fd742d7570dfd1007
-rw-r--r--Android.mk6
-rw-r--r--AndroidManifest.xml2
2 files changed, 4 insertions, 4 deletions
diff --git a/Android.mk b/Android.mk
index 811322f..b4584a4 100644
--- a/Android.mk
+++ b/Android.mk
@@ -83,7 +83,7 @@ LOCAL_PROTOC_FLAGS := --proto_path=$(LOCAL_PATH)/protos/ --proto_path=$(LOCAL_PA
LOCAL_PROTO_JAVA_OUTPUT_PARAMS := enum_style=java
LOCAL_SDK_VERSION := current
-LOCAL_MIN_SDK_VERSION := 21
+LOCAL_MIN_SDK_VERSION := 26
LOCAL_MODULE := Launcher3CommonDepsLib
LOCAL_PRIVILEGED_MODULE := true
LOCAL_MANIFEST_FILE := AndroidManifest-common.xml
@@ -111,7 +111,7 @@ LOCAL_PROGUARD_FLAG_FILES := proguard.flags
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_SDK_VERSION := current
-LOCAL_MIN_SDK_VERSION := 21
+LOCAL_MIN_SDK_VERSION := 26
LOCAL_PACKAGE_NAME := Trebuchet
LOCAL_PRIVILEGED_MODULE := true
LOCAL_PRODUCT_MODULE := true
@@ -142,7 +142,7 @@ LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/go/res
LOCAL_PROGUARD_FLAG_FILES := proguard.flags
LOCAL_SDK_VERSION := current
-LOCAL_MIN_SDK_VERSION := 21
+LOCAL_MIN_SDK_VERSION := 26
LOCAL_PACKAGE_NAME := TrebuchetGo
LOCAL_PRIVILEGED_MODULE := true
LOCAL_PRODUCT_MODULE := true
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index dfdf8bb..b73ffdd 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -21,7 +21,7 @@
xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:tools="http://schemas.android.com/tools"
package="com.android.launcher3">
- <uses-sdk android:targetSdkVersion="29" android:minSdkVersion="25"/>
+ <uses-sdk android:targetSdkVersion="29" android:minSdkVersion="26"/>
<!--
Manifest entries specific to Launcher3. This is merged with AndroidManifest-common.xml.
Refer comments around specific entries on how to extend individual components.