aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1999-09-11 04:50:44 +0000
committerGerald Combs <gerald@wireshark.org>1999-09-11 04:50:44 +0000
commit9386f23feeb16591875734ba98c32604c9f44441 (patch)
tree6334aee6608029bfc8008d31a2e3647ce14e81bc /wiretap/Makefile.am
parent078f9a67b9d92e080282a2d7743bbfd2e0145698 (diff)
downloadwireshark-9386f23feeb16591875734ba98c32604c9f44441.tar.gz
wireshark-9386f23feeb16591875734ba98c32604c9f44441.tar.bz2
wireshark-9386f23feeb16591875734ba98c32604c9f44441.zip
Added support for Lucent/Ascend packet traces. The MAX and Pipeline router
family has a set of debug commands that allow you to log the traffic on a WAN or dialup connection as text, e.g. RECV-iguana:241:(task: B04E12C0, time: 1975358.50) 15 octets @ 8003D634 [0000]: FF 03 00 3D C0 06 C9 96 2D 04 C1 72 00 05 B8 Created wtap_seek_read() which parses the textual data for and Ascend trace, and does a normal fseek() and fread() for any other file type. The fseek()/fread() pairs in file.c were replaced with the new function. svn path=/trunk/; revision=652
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index ad1bf805de..048120cabd 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Wiretap
#
-# $Id: Makefile.am,v 1.19 1999/09/09 03:54:38 guy Exp $
+# $Id: Makefile.am,v 1.20 1999/09/11 04:50:43 gerald Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -31,6 +31,10 @@ CLEANFILES = \
*~
libwiretap_a_SOURCES = \
+ ascend-grammar.y \
+ ascend-scanner.l \
+ ascend.c \
+ ascend.h \
buffer.c \
buffer.h \
file.c \
@@ -56,3 +60,9 @@ libwiretap_a_SOURCES = \
EXTRA_DIST = \
config.h.win32 \
Makefile.nmake
+
+# Any POSIX-compatible YACC should honor the -p flag
+YFLAGS=-d -p ascend
+
+ascend-scanner.c : ascend-scanner.l
+ $(LEX) -Pascend -t $(srcdir)/ascend-scanner.l > ascend-scanner.c