aboutsummaryrefslogtreecommitdiffstats
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorLaurent Deniel <laurent.deniel@free.fr>2000-08-13 14:09:15 +0000
committerLaurent Deniel <laurent.deniel@free.fr>2000-08-13 14:09:15 +0000
commitcc36f0b9312fc36778bf227cbaaf02c89baf09b3 (patch)
tree0aff9b70a00a628a713030dc9000f3b5492d492b /gtk/Makefile.am
parentdb31ba13c8b9f82c1b96b5444fe3b7e8ff109ce1 (diff)
downloadwireshark-cc36f0b9312fc36778bf227cbaaf02c89baf09b3.tar.gz
wireshark-cc36f0b9312fc36778bf227cbaaf02c89baf09b3.tar.bz2
wireshark-cc36f0b9312fc36778bf227cbaaf02c89baf09b3.zip
Add the "Edit:Protocols..." feature which currently only implements
the following: It is now possible to enable/disable a particular protocol decoding (i.e. the protocol dissector is void or not). When a protocol is disabled, it is displayed as Data and of course, all linked sub-protocols are disabled as well. Disabling a protocol could be interesting: - in case of buggy dissectors - in case of wrong heuristics - for performance reasons - to decode the data as another protocol (TODO) Currently (if I am not wrong), all dissectors but NFS can be disabled (and dissectors that do not register protocols :-) I do not like the way the RPC sub-dissectors are disabled (in the sub-dissectors) since this could be done in the RPC dissector itself, knowing the sub-protocol hfinfo entry (this is why, I've not modified the NFS one yet). Two functions are added in proto.c : gboolean proto_is_protocol_enabled(int n); void proto_set_decoding(int n, gboolean enabled); and two MACROs which can be used in dissectors: OLD_CHECK_DISPLAY_AS_DATA(index, pd, offset, fd, tree) CHECK_DISPLAY_AS_DATA(index, tvb, pinfo, tree) See also the XXX in proto_dlg.c and proto.c around the new functions. svn path=/trunk/; revision=2267
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index bda475a3d4..9a2b245828 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for the GTK interface routines for Ethereal
#
-# $Id: Makefile.am,v 1.29 2000/08/08 12:24:31 deniel Exp $
+# $Id: Makefile.am,v 1.30 2000/08/13 14:03:49 deniel Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -72,6 +72,8 @@ libui_a_SOURCES = \
print_prefs.c \
print_prefs.h \
progress_dlg.c \
+ proto_dlg.c \
+ proto_dlg.h \
proto_draw.c \
proto_draw.h \
simple_dialog.c \