aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>1999-10-11 07:38:21 +0000
committerGuy Harris <guy@alum.mit.edu>1999-10-11 07:38:21 +0000
commitfa489de71b4a6ec90b8ba6bc0354e892fd3fb108 (patch)
tree805aae2df9f2046e72c3ffd25386189bef1896be /configure.in
parent6b5159e8deeebf126fc734454a7e1414acfb38da (diff)
downloadwireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.tar.gz
wireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.tar.bz2
wireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.zip
Solaris 7 doesn't have "inet_aton()", either; supply our own version on
OSes that don't have it. (Yes, this is BSD code, not GPLed code. I tried getting it from Glibc, but the glibc version is just the BSD version, so I guess it's OK to mix BSD code in with GPLed code, or, at least, with LGPLed code....) svn path=/trunk/; revision=805
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ee3a5f6720..d792c340ff 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.48 1999/10/01 21:41:38 guy Exp $
+# $Id: configure.in,v 1.49 1999/10/11 07:38:21 guy Exp $
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etypes.h)
@@ -183,6 +183,15 @@ fi
AC_SUBST(MKSTEMP_C)
AC_SUBST(MKSTEMP_O)
+AC_CHECK_FUNC(inet_aton, INET_ADDR_O="",
+ INET_ATON_O="inet_aton.o")
+if test "$ac_cv_func_inet_aton" = no ; then
+ INET_ATON_C="inet_aton.c"
+ INET_ATON_O="inet_aton.o"
+fi
+AC_SUBST(INET_ATON_C)
+AC_SUBST(INET_ATON_O)
+
dnl blank for now, but will be used in future
AC_SUBST(ethereal_SUBDIRS)