aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-12-07 22:56:58 +0000
committerGuy Harris <guy@alum.mit.edu>2001-12-07 22:56:58 +0000
commitf85f8bf4664677a12b2255c1c6f6ca38275bd486 (patch)
treef9a9efe09ec90fcb95952e3092ed28c8e44f5854 /configure.in
parent6bb3e341d1db89d10ab49d9f24ac766e0593999e (diff)
downloadwireshark-f85f8bf4664677a12b2255c1c6f6ca38275bd486.tar.gz
wireshark-f85f8bf4664677a12b2255c1c6f6ca38275bd486.tar.bz2
wireshark-f85f8bf4664677a12b2255c1c6f6ca38275bd486.zip
Use "-no-cpp-precomp" rather than "-traditional-cpp" on MacOS X, as per
the "The Compiler and Tools" section on http://fink.sourceforge.net/doc/porting/basics.php Do so on MacOS X regardless of whether the compiler is called "gcc" or not, as that page also indicates that the compiler is installed as "cc". svn path=/trunk/; revision=4354
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index dd99440485..b292481b2c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.140 2001/11/02 10:01:00 guy Exp $
+# $Id: configure.in,v 1.141 2001/12/07 22:56:56 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -109,6 +109,17 @@ then
CFLAGS="-Ae +O2 $CFLAGS"
AC_MSG_RESULT(HP ANSI C compiler - added -Ae +O2)
;;
+ darwin*)
+ #
+ # It may be called "cc", but it's really a GCC derivative
+ # with a problematic special precompiler and precompiled
+ # headers; turn off the special precompiler, as some
+ # apparently-legal code won't compile with its precompiled
+ # headers.
+ #
+ CFLAGS="-no-cpp-precomp $CFLAGS"
+ AC_MSG_RESULT(Apple GCC - added -no-cpp-precomp)
+ ;;
*)
AC_MSG_RESULT(none needed)
;;
@@ -122,8 +133,11 @@ else
AC_MSG_RESULT(GCC on Solaris - added -Wno-return-type -DFUNCPROTO=15)
;;
darwin*)
- CFLAGS="-traditional-cpp $CFLAGS"
- AC_MSG_RESULT(Apple cc compiler - added -traditional-cpp)
+ #
+ # See comments above about Apple's lovely C compiler.
+ #
+ CFLAGS="-no-cpp-precomp $CFLAGS"
+ AC_MSG_RESULT(Apple GCC - added -no-cpp-precomp)
;;
*)
AC_MSG_RESULT(none needed)