aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-07-27 06:10:26 +0000
committerGuy Harris <guy@alum.mit.edu>2001-07-27 06:10:26 +0000
commit8a9917a9a7528d4bdac5e9d3e4aa8a1080d06b4c (patch)
tree64263c22d51e6f952ad394a2a8c67d706e95770c /configure.in
parent3322b11fc2062b2e1b50d8c94ab31d5680d442ef (diff)
downloadwireshark-8a9917a9a7528d4bdac5e9d3e4aa8a1080d06b4c.tar.gz
wireshark-8a9917a9a7528d4bdac5e9d3e4aa8a1080d06b4c.tar.bz2
wireshark-8a9917a9a7528d4bdac5e9d3e4aa8a1080d06b4c.zip
If GLib doesn't support loadable modules, don't let the user enable
plugins. (This means that "--with-plugins" with no argument is useless - if GLib supports loadable modules, plugins are enabled by default, and if GLib doesn't support loadable modules, plugins can't be enabled - but with an argument, it lets you specify a different directory into which to put plugins.) svn path=/trunk/; revision=3791
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 96e9665255..2c436add08 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.135 2001/07/26 22:05:01 guy Exp $
+# $Id: configure.in,v 1.136 2001/07/27 06:10:26 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -596,11 +596,19 @@ AC_ARG_WITH(plugins,
[
case "$withval" in
"" | y | ye | yes )
+ if test x$have_plugins = xno
+ then
+ AC_MSG_ERROR([GLib on this platform doesn't support loadable modules, so you can't enable plugins.])
+ fi
;;
n | no)
have_plugins=no
;;
*)
+ if test x$have_plugins = xno
+ then
+ AC_MSG_ERROR([GLib on this platform doesn't support loadable modules, so you can't enable plugins.])
+ fi
PLUGIN_DIR="$withval"
;;
esac