aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-01-30 10:05:07 +0000
committerGuy Harris <guy@alum.mit.edu>2002-01-30 10:05:07 +0000
commit7bd0d9a4f705dc0538683f9bcd6971e464cd4e50 (patch)
tree9528bb718d442da32ef2064995ad715a79fadac8 /configure.in
parent5ec8fb43a559401ee5cb5727a23f088bd827ec04 (diff)
downloadwireshark-7bd0d9a4f705dc0538683f9bcd6971e464cd4e50.tar.gz
wireshark-7bd0d9a4f705dc0538683f9bcd6971e464cd4e50.tar.bz2
wireshark-7bd0d9a4f705dc0538683f9bcd6971e464cd4e50.zip
Solaris's "/usr/ucb/sed" isn't good enough either.
svn path=/trunk/; revision=4628
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 649c4d0732..5100dfe5a5 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.147 2002/01/30 08:01:15 guy Exp $
+# $Id: configure.in,v 1.148 2002/01/30 10:05:07 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -155,9 +155,10 @@ AC_SUBST(DATAFILE_DIR)
# If we're running Solaris, and LD_LIBRARY_PATH is defined, add it as a
# link directory.
#
-# Also, make sure that "sed" does *NOT* refer to "/usr/bin/sed", as
-# "/usr/bin/sed" is inadequate to handle, in libtool, a list of
-# object files as large as the list in Ethereal.
+# Also, make sure that "sed" does *NOT* refer to "/usr/bin/sed" or
+# "/usr/ucb/sed", as, on Solaris, both of them are inadequate to
+# handle, in libtool, a list of object files as large as the list
+# in Ethereal.
#
case "$host_os" in
solaris*)
@@ -168,13 +169,17 @@ case "$host_os" in
else
AC_MSG_RESULT(no -- this may be a problem in a few seconds)
fi
- AC_MSG_CHECKING(whether /usr/bin/sed will be used)
- if test `which sed` = /usr/bin/sed ; then
- AC_MSG_RESULT(yes)
- AC_MSG_ERROR(change your path to search /usr/xpg4/bin before /usr/bin)
- else
+ AC_MSG_CHECKING(whether one of /usr/bin/sed or /usr/ucb/sed will be used)
+ case `which sed` in
+ /usr/bin/sed|/usr/ucb/sed)
+ AC_MSG_RESULT(yes)
+ AC_MSG_ERROR([change your path to search /usr/xpg4/bin before /usr/bin (and /usr/ucb)])
+ ;;
+
+ *)
AC_MSG_RESULT(no)
- fi
+ ;;
+ esac
;;
esac