aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1998-11-18 04:02:17 +0000
committerGerald Combs <gerald@wireshark.org>1998-11-18 04:02:17 +0000
commitdae8277e2013df722ec9124c3e5bcd2c80147df9 (patch)
tree08e0e5b31ec962bce54c2aa7114819ecf27de89f /configure.in
parent369407d7b0e845cb8aa650664d03ca7bdb18db7c (diff)
downloadwireshark-dae8277e2013df722ec9124c3e5bcd2c80147df9.tar.gz
wireshark-dae8277e2013df722ec9124c3e5bcd2c80147df9.tar.bz2
wireshark-dae8277e2013df722ec9124c3e5bcd2c80147df9.zip
* Don't build wiretap if it isn't configured.
* Bump the version to 0.5.0 svn path=/trunk/; revision=106
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 7b738c19c2..fe139c2a05 100644
--- a/configure.in
+++ b/configure.in
@@ -1,8 +1,8 @@
-# $Id: configure.in,v 1.16 1998/11/18 01:40:09 gerald Exp $
+# $Id: configure.in,v 1.17 1998/11/18 04:02:17 gerald Exp $
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etypes.h)
-AM_INIT_AUTOMAKE(ethereal, 0.4.2)
+AM_INIT_AUTOMAKE(ethereal, 0.5.0)
dnl Check for CPU / vendor / OS
AC_CANONICAL_HOST
@@ -81,15 +81,18 @@ AC_ARG_WITH(wiretap,
AC_DEFINE(WITH_WIRETAP)
CFLAGS="$CFLAGS -Iwiretap"
LIBWIRETAP_A="wiretap/libwiretap.a"
+ WIRETAP_DIR="wiretap"
;;
*)
AC_MSG_RESULT(no)
LIBWIRETAP_A=""
+ WIRETAP_DIR=""
;;
esac ],
AC_MSG_RESULT(no)
)
AC_SUBST(LIBWIRETAP_A)
+AC_SUBST(WIRETAP_DIR)
dnl Checks for header files.
AC_HEADER_STDC
@@ -126,5 +129,7 @@ AC_SUBST(SNPRINTF_C)
AC_SUBST(SNPRINTF_O)
AM_CONFIG_HEADER(config.h)
-AC_CONFIG_SUBDIRS(wiretap)
+if test x$WIRETAP_DIR != x ; then
+ AC_CONFIG_SUBDIRS(wiretap)
+fi
AC_OUTPUT(Makefile)