aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1998-10-12 01:40:57 +0000
committerGerald Combs <gerald@wireshark.org>1998-10-12 01:40:57 +0000
commit0758da11466778cbd377fade6142bbe7c19ceecd (patch)
treef57ee7de708d072038153022c1ccbd9afa448651 /configure.in
parent73e19611fdb5a6b70951c140c0831c72f04beb5c (diff)
downloadwireshark-0758da11466778cbd377fade6142bbe7c19ceecd.tar.gz
wireshark-0758da11466778cbd377fade6142bbe7c19ceecd.tar.bz2
wireshark-0758da11466778cbd377fade6142bbe7c19ceecd.zip
- Added match_strval function to packet.c
- Separated display and capture filters; rearranged some of the look and feel - Lots of other miscellaneous fixes and updates svn path=/trunk/; revision=38
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 4872cc7ddc..2dcdbd9753 100644
--- a/configure.in
+++ b/configure.in
@@ -1,8 +1,8 @@
-# $Id: configure.in,v 1.6 1998/10/10 03:32:05 gerald Exp $
+# $Id: configure.in,v 1.7 1998/10/12 01:40:46 gerald Exp $
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etypes.h)
-AM_INIT_AUTOMAKE(ethereal, 0.3.18)
+AM_INIT_AUTOMAKE(ethereal, 0.4.0)
dnl Check for CPU / vendor / OS
AC_CANONICAL_HOST
@@ -44,8 +44,8 @@ AC_CHECK_HEADER(net/bpf.h,, AC_MSG_ERROR(Header file net/bpf.h not found.))
AC_CHECK_LIB(pcap, pcap_open_offline,, AC_MSG_ERROR(Library libpcap not found.))
dnl Checks for header files.
-# AC_HEADER_STDC
-# AC_CHECK_HEADERS(fcntl.h strings.h sys/ioctl.h sys/time.h unistd.h)
+AC_HEADER_STDC
+AC_CHECK_HEADERS(fcntl.h strings.h sys/ioctl.h sys/time.h unistd.h stdarg.h)
AC_CHECK_HEADERS(sys/sockio.h sys/types.h netinet/in.h)
@@ -65,8 +65,14 @@ AC_CHECK_FUNC(socket,, AC_MSG_ERROR(Function 'socket' not found.))
# If there's a system out there that has snprintf and _doesn't_ have vsnprintf,
# then this won't work.
-AC_CHECK_FUNC(snprintf, SNPRINTF_C="" SNPRINTF_O="",
- SNPRINTF_C="snprintf.c" SNPRINTF_O="snprintf.o" AC_DEFINE(NEED_SNPRINTF_H))
+SNPRINTF_C=""
+SNPRINTF_O=""
+AC_CHECK_FUNC(snprintf, SNPRINTF_O="",
+ SNPRINTF_O="snprintf.o" [AC_DEFINE(NEED_SNPRINTF_H)])
+if test "$ac_cv_func_snprintf" = no ; then
+ SNPRINTF_C="snprintf.c"
+ SNPRINTF_O="snprintf.o"
+fi
AC_SUBST(SNPRINTF_C)
AC_SUBST(SNPRINTF_O)