aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>1999-10-11 07:38:21 +0000
committerGuy Harris <guy@alum.mit.edu>1999-10-11 07:38:21 +0000
commitfa489de71b4a6ec90b8ba6bc0354e892fd3fb108 (patch)
tree805aae2df9f2046e72c3ffd25386189bef1896be /Makefile.am
parent6b5159e8deeebf126fc734454a7e1414acfb38da (diff)
downloadwireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.tar.gz
wireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.tar.bz2
wireshark-fa489de71b4a6ec90b8ba6bc0354e892fd3fb108.zip
Solaris 7 doesn't have "inet_aton()", either; supply our own version on
OSes that don't have it. (Yes, this is BSD code, not GPLed code. I tried getting it from Glibc, but the glibc version is just the BSD version, so I guess it's OK to mix BSD code in with GPLed code, or, at least, with LGPLed code....) svn path=/trunk/; revision=805
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 68abb47363..bcafa55bfd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.78 1999/10/08 20:50:39 guy Exp $
+# $Id: Makefile.am,v 1.79 1999/10/11 07:38:21 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -150,12 +150,14 @@ EXTRA_ethereal_SOURCES = \
strerror.c \
strerror.h \
strncasecmp.c \
- mkstemp.c
+ mkstemp.c \
+ inet_aton.c
ethereal_DEPENDENCIES = @SNMP_O@ @SNPRINTF_O@ @STRERROR_O@ \
-@STRNCASECMP_O@ @MKSTEMP_O@ wiretap/libwiretap.a gtk/libui.a
+@STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ wiretap/libwiretap.a gtk/libui.a
ethereal_LDADD = @SNMP_O@ @SNPRINTF_O@ @STRERROR_O@ \
-@STRNCASECMP_O@ @MKSTEMP_O@ wiretap/libwiretap.a gtk/libui.a @SNMP_A@
+@STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ wiretap/libwiretap.a gtk/libui.a \
+@SNMP_A@
ps.c: print.ps rdps
./rdps $(srcdir)/print.ps ps.c