aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-02-11 14:24:18 -0800
committerGerald Combs <gerald@wireshark.org>2019-02-14 23:11:15 +0000
commit23c9a1e036445c17ec4bbc5d0fcbea4f588253c1 (patch)
tree37fa8cffa8ae7a2fd2cf42e3a1d85749ec3a40f3 /CMakeLists.txt
parentef0ef16c30a8a217645e06df47eb4e5718dabb0b (diff)
downloadwireshark-23c9a1e036445c17ec4bbc5d0fcbea4f588253c1.tar.gz
wireshark-23c9a1e036445c17ec4bbc5d0fcbea4f588253c1.tar.bz2
wireshark-23c9a1e036445c17ec4bbc5d0fcbea4f588253c1.zip
Convert the FAQ to Asciidoctor and remove old help files.
Convert our self-generating FAQ to Asciidoctor via the following steps: - `help/faq.py > /tmp/faq.html`. - `pandoc -t asciidoc -o docbook/faq.adoc /tmp/faq.html`. - Manually clean up the markup using a text editor. Question and answer content was left intact. Removing or updating obsolete content will have to be done in a separate change. The Asciidoctor project uses the .adoc extension, so start using it here as well. The contents of the "help" directory appear to have been used for offline support in help_url.c, but that functionality was removed in 2008 in 242e3b78bc. Its content is covered in the User's Guide and man pages so remove it. Change-Id: I9060eefe97cfc137f8b414077c30f814379b576a Reviewed-on: https://code.wireshark.org/review/32014 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt58
1 files changed, 3 insertions, 55 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a2d37e820..6bfd0dcb47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1638,15 +1638,6 @@ set(INSTALL_DIRS
wimaxasncp
)
-# FIXME: The help files are textfified on Windows into the staging dir.
-# The DATAFILE_DIR depends on CMAKE_CFG_INTDIR therefore it cannot be
-# added to an install() command with build systems supporting multiple
-# configurations in the build tree (e.g.: Visual Studio).
-if(NOT WIN32)
- list(APPEND INSTALL_DIRS help)
-endif()
-
-
set(INSTALL_FILES
cfilters
colorfilters
@@ -1883,12 +1874,6 @@ endif(WIN32)
# List of extra dependencies for the "copy_data_files" target
set(copy_data_files_depends)
-# glob patterns relative to the source directory that should be copied to
-# ${DATAFILE_DIR} (including directory prefixes)
-set(DATA_FILES_SRC
- "help/toc"
-)
-
if(WIN32)
foreach(_text_file ${TEXTIFY_FILES})
add_custom_command(OUTPUT ${CMAKE_BINARY_DIR}/${_text_file}.txt
@@ -1929,45 +1914,6 @@ foreach(_install_file ${INSTALL_FILES})
list(APPEND copy_data_files_depends "${_output_file}")
endforeach()
-# faq.txt is handled separately below.
-set(_help_source_files
- help/capture_filters.txt
- help/capturing.txt
- help/display_filters.txt
- help/getting_started.txt
- help/overview.txt
-)
-
-if(WIN32)
- file(TO_NATIVE_PATH "${DATAFILE_DIR}/help" _help_dest_dir)
- foreach(_help_file IN LISTS _help_source_files)
- add_custom_command(OUTPUT "${DATAFILE_DIR}/${_help_file}"
- COMMAND ${CMAKE_COMMAND} -E make_directory "${DATAFILE_DIR}/help"
- COMMAND ${POWERSHELL_COMMAND} "${CMAKE_SOURCE_DIR}/tools/textify.ps1"
- -Destination "${_help_dest_dir}"
- "${CMAKE_SOURCE_DIR}/${_help_file}"
- DEPENDS
- "${CMAKE_SOURCE_DIR}/${_help_file}"
- )
- list(APPEND copy_data_files_depends "${DATAFILE_DIR}/${_help_file}")
- endforeach()
-else()
- list(APPEND DATA_FILES_SRC ${_help_source_files})
-endif(WIN32)
-
-# Create help/faq.txt when missing
-add_custom_command(OUTPUT "${DATAFILE_DIR}/help/faq.txt"
- COMMAND ${CMAKE_COMMAND} -E make_directory "${DATAFILE_DIR}/help"
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/help/faq.py -b > faq.tmp.html
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/html2text.py
- faq.tmp.html > "${DATAFILE_DIR}/help/faq.txt"
- COMMAND ${CMAKE_COMMAND} -E remove faq.tmp.html
- DEPENDS
- "${CMAKE_SOURCE_DIR}/help/faq.py"
- "${CMAKE_SOURCE_DIR}/tools/html2text.py"
-)
-list(APPEND copy_data_files_depends "${DATAFILE_DIR}/help/faq.txt")
-
# Install LUA files in staging directory such that LUA can used when Wireshark
# is ran from the build directory. For install targets, see
# epan/wslua/CMakeLists.txt
@@ -1993,8 +1939,10 @@ if(LUA_FOUND AND ENABLE_LUA)
endif(LUA_FOUND AND ENABLE_LUA)
# doc/*.html handled elsewhere.
+# Glob patterns relative to the source directory that should be copied to
+# ${DATAFILE_DIR} (including directory prefixes)
# TODO shouldn't this use full (relative) paths instead of glob patterns?
-list(APPEND DATA_FILES_SRC
+set(DATA_FILES_SRC
"tpncp/tpncp.dat"
"wimaxasncp/*.dtd"
"wimaxasncp/*.xml"