aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-12-02 22:15:08 +0000
committerAnders Broman <a.broman58@gmail.com>2015-12-03 05:02:46 +0000
commit0223249c8c74794a06ae76b29e12681ad5e3ebe4 (patch)
tree73d2888f753d77dd078fa759b4df94286ec7c822 /CMakeLists.txt
parent0f98c6f0dd107d12ce60bb621315eceb2e75501c (diff)
downloadwireshark-0223249c8c74794a06ae76b29e12681ad5e3ebe4.tar.gz
wireshark-0223249c8c74794a06ae76b29e12681ad5e3ebe4.tar.bz2
wireshark-0223249c8c74794a06ae76b29e12681ad5e3ebe4.zip
CMake+PortableApps: Include the VC runtime.
Move the code that finds the Visual C++ redistributable DLLs to its own module. Run it before we create our NSIS and PortableApps targets. Add a PortableApps target that copies the redistributable. Bug: 11800 Change-Id: I61aeac041386b17c8f3c1d2a8cfb7b210bf98f84 Reviewed-on: https://code.wireshark.org/review/12390 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa8743d8a1..7ddcce9503 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2245,6 +2245,8 @@ if(BUILD_dumpcap AND PCAP_FOUND)
endif()
if (WIN32)
+ find_package( MSVC_REDIST )
+
# Must come after executable targets are defined.
find_package( NSIS )