aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.d/tools/objtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/tools/objtool/Makefile')
-rw-r--r--debian/rules.d/tools/objtool/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules.d/tools/objtool/Makefile b/debian/rules.d/tools/objtool/Makefile
index cc2ea9e2201d..6b42618d3000 100644
--- a/debian/rules.d/tools/objtool/Makefile
+++ b/debian/rules.d/tools/objtool/Makefile
@@ -5,7 +5,7 @@ all:
# for multiple targets and add a wrapper, same as for modpost.
# objtool explicitly sets CC and LD to be native tools; we need to override
# this on the command line to make cross-builds work.
- $(MAKE) -C $(top_srcdir)/tools/objtool O=$(CURDIR) ARCH=x86 CC=$(CC) LD=$(CROSS_COMPILE)ld
+ $(MAKE) -C $(top_srcdir)/tools/objtool O=$(CURDIR) HOSTARCH=$(KERNEL_ARCH) ARCH=x86 CC=$(CC) LD=$(CROSS_COMPILE)ld
install:
install -D -m755 objtool $(DESTDIR)/$(installdir)/objtool