aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff')
-rw-r--r--debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff348
1 files changed, 348 insertions, 0 deletions
diff --git a/debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff b/debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff
new file mode 100644
index 000000000000..988f73472fad
--- /dev/null
+++ b/debian/patches/bugfix/m68k/m68k-mvme-scsi-rename.diff
@@ -0,0 +1,348 @@
+Subject: [PATCH] m68k: BVME6000 and MVME16x SCSI driver rename
+
+Rename the source files for the BVME6000 and MVME16x SCSI drivers from *.c to
+*_scsi.c
+
+Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
+
+---
+ drivers/scsi/Makefile | 4 +-
+ drivers/scsi/bvme6000.c | 76 -----------------------------------------
+ drivers/scsi/bvme6000_scsi.c | 76 +++++++++++++++++++++++++++++++++++++++++
+ drivers/scsi/mvme16x.c | 78 -------------------------------------------
+ drivers/scsi/mvme16x_scsi.c | 78 +++++++++++++++++++++++++++++++++++++++++++
+ 5 files changed, 156 insertions(+), 156 deletions(-)
+
+--- linux-m68k-2.6.21.orig/drivers/scsi/Makefile
++++ linux-m68k-2.6.21/drivers/scsi/Makefile
+@@ -53,8 +53,8 @@ obj-$(CONFIG_ATARI_SCSI) += atari_scsi.o
+ obj-$(CONFIG_MAC_SCSI) += mac_scsi.o
+ obj-$(CONFIG_SCSI_MAC_ESP) += mac_esp.o NCR53C9x.o
+ obj-$(CONFIG_SUN3_SCSI) += sun3_scsi.o sun3_scsi_vme.o
+-obj-$(CONFIG_MVME16x_SCSI) += mvme16x.o 53c7xx.o
+-obj-$(CONFIG_BVME6000_SCSI) += bvme6000.o 53c7xx.o
++obj-$(CONFIG_MVME16x_SCSI) += mvme16x_scsi.o 53c7xx.o
++obj-$(CONFIG_BVME6000_SCSI) += bvme6000_scsi.o 53c7xx.o
+ obj-$(CONFIG_SCSI_SIM710) += 53c700.o sim710.o
+ obj-$(CONFIG_SCSI_ADVANSYS) += advansys.o
+ obj-$(CONFIG_SCSI_PSI240I) += psi240i.o
+--- linux-m68k-2.6.21.orig/drivers/scsi/bvme6000.c
++++ /dev/null
+@@ -1,76 +0,0 @@
+-/*
+- * Detection routine for the NCR53c710 based BVME6000 SCSI Controllers for Linux.
+- *
+- * Based on work by Alan Hourihane
+- */
+-#include <linux/types.h>
+-#include <linux/mm.h>
+-#include <linux/blkdev.h>
+-#include <linux/zorro.h>
+-
+-#include <asm/setup.h>
+-#include <asm/page.h>
+-#include <asm/pgtable.h>
+-#include <asm/bvme6000hw.h>
+-#include <asm/irq.h>
+-
+-#include "scsi.h"
+-#include <scsi/scsi_host.h>
+-#include "53c7xx.h"
+-#include "bvme6000.h"
+-
+-#include<linux/stat.h>
+-
+-
+-int bvme6000_scsi_detect(struct scsi_host_template *tpnt)
+-{
+- static unsigned char called = 0;
+- int clock;
+- long long options;
+-
+- if (called)
+- return 0;
+- if (!MACH_IS_BVME6000)
+- return 0;
+-
+- tpnt->proc_name = "BVME6000";
+-
+- options = OPTION_MEMORY_MAPPED|OPTION_DEBUG_TEST1|OPTION_INTFLY|OPTION_SYNCHRONOUS|OPTION_ALWAYS_SYNCHRONOUS|OPTION_DISCONNECT;
+-
+- clock = 40000000; /* 66MHz SCSI Clock */
+-
+- ncr53c7xx_init(tpnt, 0, 710, (unsigned long)BVME_NCR53C710_BASE,
+- 0, BVME_IRQ_SCSI, DMA_NONE,
+- options, clock);
+- called = 1;
+- return 1;
+-}
+-
+-static int bvme6000_scsi_release(struct Scsi_Host *shost)
+-{
+- if (shost->irq)
+- free_irq(shost->irq, NULL);
+- if (shost->dma_channel != 0xff)
+- free_dma(shost->dma_channel);
+- if (shost->io_port && shost->n_io_port)
+- release_region(shost->io_port, shost->n_io_port);
+- scsi_unregister(shost);
+- return 0;
+-}
+-
+-static struct scsi_host_template driver_template = {
+- .name = "BVME6000 NCR53c710 SCSI",
+- .detect = bvme6000_scsi_detect,
+- .release = bvme6000_scsi_release,
+- .queuecommand = NCR53c7xx_queue_command,
+- .abort = NCR53c7xx_abort,
+- .reset = NCR53c7xx_reset,
+- .can_queue = 24,
+- .this_id = 7,
+- .sg_tablesize = 63,
+- .cmd_per_lun = 3,
+- .use_clustering = DISABLE_CLUSTERING
+-};
+-
+-
+-#include "scsi_module.c"
+--- /dev/null
++++ linux-m68k-2.6.21/drivers/scsi/bvme6000_scsi.c
+@@ -0,0 +1,76 @@
++/*
++ * Detection routine for the NCR53c710 based BVME6000 SCSI Controllers for Linux.
++ *
++ * Based on work by Alan Hourihane
++ */
++#include <linux/types.h>
++#include <linux/mm.h>
++#include <linux/blkdev.h>
++#include <linux/zorro.h>
++
++#include <asm/setup.h>
++#include <asm/page.h>
++#include <asm/pgtable.h>
++#include <asm/bvme6000hw.h>
++#include <asm/irq.h>
++
++#include "scsi.h"
++#include <scsi/scsi_host.h>
++#include "53c7xx.h"
++#include "bvme6000.h"
++
++#include<linux/stat.h>
++
++
++int bvme6000_scsi_detect(struct scsi_host_template *tpnt)
++{
++ static unsigned char called = 0;
++ int clock;
++ long long options;
++
++ if (called)
++ return 0;
++ if (!MACH_IS_BVME6000)
++ return 0;
++
++ tpnt->proc_name = "BVME6000";
++
++ options = OPTION_MEMORY_MAPPED|OPTION_DEBUG_TEST1|OPTION_INTFLY|OPTION_SYNCHRONOUS|OPTION_ALWAYS_SYNCHRONOUS|OPTION_DISCONNECT;
++
++ clock = 40000000; /* 66MHz SCSI Clock */
++
++ ncr53c7xx_init(tpnt, 0, 710, (unsigned long)BVME_NCR53C710_BASE,
++ 0, BVME_IRQ_SCSI, DMA_NONE,
++ options, clock);
++ called = 1;
++ return 1;
++}
++
++static int bvme6000_scsi_release(struct Scsi_Host *shost)
++{
++ if (shost->irq)
++ free_irq(shost->irq, NULL);
++ if (shost->dma_channel != 0xff)
++ free_dma(shost->dma_channel);
++ if (shost->io_port && shost->n_io_port)
++ release_region(shost->io_port, shost->n_io_port);
++ scsi_unregister(shost);
++ return 0;
++}
++
++static struct scsi_host_template driver_template = {
++ .name = "BVME6000 NCR53c710 SCSI",
++ .detect = bvme6000_scsi_detect,
++ .release = bvme6000_scsi_release,
++ .queuecommand = NCR53c7xx_queue_command,
++ .abort = NCR53c7xx_abort,
++ .reset = NCR53c7xx_reset,
++ .can_queue = 24,
++ .this_id = 7,
++ .sg_tablesize = 63,
++ .cmd_per_lun = 3,
++ .use_clustering = DISABLE_CLUSTERING
++};
++
++
++#include "scsi_module.c"
+--- linux-m68k-2.6.21.orig/drivers/scsi/mvme16x.c
++++ /dev/null
+@@ -1,78 +0,0 @@
+-/*
+- * Detection routine for the NCR53c710 based MVME16x SCSI Controllers for Linux.
+- *
+- * Based on work by Alan Hourihane
+- */
+-#include <linux/types.h>
+-#include <linux/mm.h>
+-#include <linux/blkdev.h>
+-
+-#include <asm/page.h>
+-#include <asm/pgtable.h>
+-#include <asm/mvme16xhw.h>
+-#include <asm/irq.h>
+-
+-#include "scsi.h"
+-#include <scsi/scsi_host.h>
+-#include "53c7xx.h"
+-#include "mvme16x.h"
+-
+-#include<linux/stat.h>
+-
+-
+-int mvme16x_scsi_detect(struct scsi_host_template *tpnt)
+-{
+- static unsigned char called = 0;
+- int clock;
+- long long options;
+-
+- if (!MACH_IS_MVME16x)
+- return 0;
+- if (mvme16x_config & MVME16x_CONFIG_NO_SCSICHIP) {
+- printk ("SCSI detection disabled, SCSI chip not present\n");
+- return 0;
+- }
+- if (called)
+- return 0;
+-
+- tpnt->proc_name = "MVME16x";
+-
+- options = OPTION_MEMORY_MAPPED|OPTION_DEBUG_TEST1|OPTION_INTFLY|OPTION_SYNCHRONOUS|OPTION_ALWAYS_SYNCHRONOUS|OPTION_DISCONNECT;
+-
+- clock = 66000000; /* 66MHz SCSI Clock */
+-
+- ncr53c7xx_init(tpnt, 0, 710, (unsigned long)0xfff47000,
+- 0, MVME16x_IRQ_SCSI, DMA_NONE,
+- options, clock);
+- called = 1;
+- return 1;
+-}
+-
+-static int mvme16x_scsi_release(struct Scsi_Host *shost)
+-{
+- if (shost->irq)
+- free_irq(shost->irq, NULL);
+- if (shost->dma_channel != 0xff)
+- free_dma(shost->dma_channel);
+- if (shost->io_port && shost->n_io_port)
+- release_region(shost->io_port, shost->n_io_port);
+- scsi_unregister(shost);
+- return 0;
+-}
+-
+-static struct scsi_host_template driver_template = {
+- .name = "MVME16x NCR53c710 SCSI",
+- .detect = mvme16x_scsi_detect,
+- .release = mvme16x_scsi_release,
+- .queuecommand = NCR53c7xx_queue_command,
+- .abort = NCR53c7xx_abort,
+- .reset = NCR53c7xx_reset,
+- .can_queue = 24,
+- .this_id = 7,
+- .sg_tablesize = 63,
+- .cmd_per_lun = 3,
+- .use_clustering = DISABLE_CLUSTERING
+-};
+-
+-
+-#include "scsi_module.c"
+--- /dev/null
++++ linux-m68k-2.6.21/drivers/scsi/mvme16x_scsi.c
+@@ -0,0 +1,78 @@
++/*
++ * Detection routine for the NCR53c710 based MVME16x SCSI Controllers for Linux.
++ *
++ * Based on work by Alan Hourihane
++ */
++#include <linux/types.h>
++#include <linux/mm.h>
++#include <linux/blkdev.h>
++
++#include <asm/page.h>
++#include <asm/pgtable.h>
++#include <asm/mvme16xhw.h>
++#include <asm/irq.h>
++
++#include "scsi.h"
++#include <scsi/scsi_host.h>
++#include "53c7xx.h"
++#include "mvme16x.h"
++
++#include<linux/stat.h>
++
++
++int mvme16x_scsi_detect(struct scsi_host_template *tpnt)
++{
++ static unsigned char called = 0;
++ int clock;
++ long long options;
++
++ if (!MACH_IS_MVME16x)
++ return 0;
++ if (mvme16x_config & MVME16x_CONFIG_NO_SCSICHIP) {
++ printk ("SCSI detection disabled, SCSI chip not present\n");
++ return 0;
++ }
++ if (called)
++ return 0;
++
++ tpnt->proc_name = "MVME16x";
++
++ options = OPTION_MEMORY_MAPPED|OPTION_DEBUG_TEST1|OPTION_INTFLY|OPTION_SYNCHRONOUS|OPTION_ALWAYS_SYNCHRONOUS|OPTION_DISCONNECT;
++
++ clock = 66000000; /* 66MHz SCSI Clock */
++
++ ncr53c7xx_init(tpnt, 0, 710, (unsigned long)0xfff47000,
++ 0, MVME16x_IRQ_SCSI, DMA_NONE,
++ options, clock);
++ called = 1;
++ return 1;
++}
++
++static int mvme16x_scsi_release(struct Scsi_Host *shost)
++{
++ if (shost->irq)
++ free_irq(shost->irq, NULL);
++ if (shost->dma_channel != 0xff)
++ free_dma(shost->dma_channel);
++ if (shost->io_port && shost->n_io_port)
++ release_region(shost->io_port, shost->n_io_port);
++ scsi_unregister(shost);
++ return 0;
++}
++
++static struct scsi_host_template driver_template = {
++ .name = "MVME16x NCR53c710 SCSI",
++ .detect = mvme16x_scsi_detect,
++ .release = mvme16x_scsi_release,
++ .queuecommand = NCR53c7xx_queue_command,
++ .abort = NCR53c7xx_abort,
++ .reset = NCR53c7xx_reset,
++ .can_queue = 24,
++ .this_id = 7,
++ .sg_tablesize = 63,
++ .cmd_per_lun = 3,
++ .use_clustering = DISABLE_CLUSTERING
++};
++
++
++#include "scsi_module.c"