aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/.gitignore1
-rw-r--r--debian/changelog41
-rw-r--r--debian/config/armhf/config5
-rw-r--r--debian/config/config5
-rw-r--r--debian/config/kernelarch-x86/config23
-rw-r--r--debian/copyright31
-rw-r--r--debian/patches/bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch30
-rw-r--r--debian/patches/series1
-rw-r--r--debian/rules.d/tools/bpf/bpftool/Makefile29
-rw-r--r--debian/rules.real27
-rw-r--r--debian/templates/control.libc-dev.in3
-rw-r--r--debian/templates/control.tools-unversioned.in13
12 files changed, 205 insertions, 4 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 90a733287065..ff620d2b1af4 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -19,6 +19,7 @@
/control
/control.md5sum
/files
+/bpftool/
/hyperv-daemons/
/kernel-image-*-di*
/libcpupower*/
diff --git a/debian/changelog b/debian/changelog
index 6c11898800df..3a221cc62569 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,29 @@ linux (5.8-1~exp1) UNRELEASED; urgency=medium
* New upstream release: https://kernelnewbies.org/Linux_5.8
+ [ Jeremy Stanley ]
+ * [x86] PMIC operation region support (Closes: #925965)
+ - Enable CONFIG_PMIC_OPREGION for general ACPI support of operation
+ regions with Power Management Integrated Circuits. Turn on specific
+ opregion support for:
+ + CONFIG_BYTCRC_PMIC_OPREGION (Bay Trail Crystal Cove PMIC)
+ + CONFIG_CHTCRC_PMIC_OPREGION (Cherry Trail Crystal Cove PMIC)
+ + CONFIG_XPOWER_PMIC_OPREGION (XPower AXP288 PMIC)
+ + CONFIG_BXT_WC_PMIC_OPREGION (BXT WhiskeyCove PMIC)
+ + CONFIG_CHT_WC_PMIC_OPREGION (CHT Whiskey Cove PMIC)
+ + CONFIG_CHT_DC_TI_PMIC_OPREGION (Dollar Cove TI PMIC)
+ Additionally enable CONFIG_MFD_INTEL_PMC_BXT as a module (multi-function
+ device driver for Intel Broxton Whiskey Cove PMIC), along with
+ CONFIG_INTEL_SOC_PMIC (Crystal Cove PMIC) as a dependency for it.
+ * [x86] Fix Cherry Trail power management regression (Closes: #949886)
+ - Switch CONFIG_I2C_DESIGNWARE_PLATFORM from being compiled as a module to
+ compiled into the kernel directly, since as of kernel version 5.1 this
+ state became a dependency for CONFIG_INTEL_SOC_PMIC_CHTWC which is
+ already enabled.
+ - Enable CONFIG_USB_ROLES_INTEL_XHCI and CONFIG_TYPEC_MUX_PI3USB30532 as
+ modules, which became dependencies for the already enabled
+ CONFIG_INTEL_CHT_INT33FE as of kernel version 4.17.
+
[ Romain Perier ]
* Rebased patches onto 5.8.
@@ -39,6 +62,24 @@ linux (5.8-1~exp1) UNRELEASED; urgency=medium
* [x86] hyperv-daemons: Complete renaming of init scripts
* [x86] hyperv-daemons: Correct old names in Conflicts field of unit files
* [hppa] Use standard metadata for transitional packages
+ * bpftool: Fix version string in recursive builds
+ * Revert "linux-libc-dev: Re-add "Provides: linux-kernel-headers""
+ (Closes: #959462)
+ * mm: Enable INIT_ON_ALLOC_DEFAULT_ON. This can be reverted using the
+ kernel parameter: init_on_alloc=0
+
+ [ Christian Barcenas ]
+ * bpftool: add packaging for tools/bpf/bpftool (Closes: #896165)
+ - Thank you to Noah Meyerhans for the first iteration of packaging.
+
+ [ Thomas W ]
+ * [x86] Enable CONFIG_XIAOMI_WMI
+
+ [ Matthew Gabeler-Lee ]
+ * [x86] Re-enable APU2 LED control (Closes: 949448)
+
+ [ Joel Stanley ]
+ * [armhf] Enable NET_NCSI
-- Yves-Alexis Perez <corsac@debian.org> Wed, 24 Jun 2020 21:58:24 +0200
diff --git a/debian/config/armhf/config b/debian/config/armhf/config
index ba541d16e60d..808319d9d530 100644
--- a/debian/config/armhf/config
+++ b/debian/config/armhf/config
@@ -1547,6 +1547,11 @@ CONFIG_CMA=y
CONFIG_NET_DSA=m
##
+## file: net/ncsi/Kconfig
+##
+CONFIG_NET_NCSI=y
+
+##
## file: net/phonet/Kconfig
##
CONFIG_PHONET=m
diff --git a/debian/config/config b/debian/config/config
index 7934006f0521..9a882a6f8bc4 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -7578,6 +7578,11 @@ CONFIG_SECURITY_APPARMOR_HASH=y
CONFIG_SECURITY_APPARMOR_HASH_DEFAULT=y
##
+## file: security/Kconfig.hardening
+##
+CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y
+
+##
## file: security/integrity/Kconfig
##
CONFIG_INTEGRITY=y
diff --git a/debian/config/kernelarch-x86/config b/debian/config/kernelarch-x86/config
index 2e6da257de8c..1b787865dc12 100644
--- a/debian/config/kernelarch-x86/config
+++ b/debian/config/kernelarch-x86/config
@@ -187,6 +187,13 @@ CONFIG_ACPI_SBS=m
CONFIG_ACPI_HED=m
# CONFIG_ACPI_CUSTOM_METHOD is not set
CONFIG_ACPI_EXTLOG=y
+CONFIG_PMIC_OPREGION=y
+CONFIG_BYTCRC_PMIC_OPREGION=y
+CONFIG_CHTCRC_PMIC_OPREGION=y
+CONFIG_XPOWER_PMIC_OPREGION=y
+CONFIG_BXT_WC_PMIC_OPREGION=y
+CONFIG_CHT_WC_PMIC_OPREGION=y
+CONFIG_CHT_DC_TI_PMIC_OPREGION=y
CONFIG_X86_PM_TIMER=y
##
@@ -669,7 +676,7 @@ CONFIG_I2C_VIA=m
CONFIG_I2C_VIAPRO=m
CONFIG_I2C_SCMI=m
#. Sony Vaio Duo 13".
-CONFIG_I2C_DESIGNWARE_PLATFORM=m
+CONFIG_I2C_DESIGNWARE_PLATFORM=y
CONFIG_I2C_DESIGNWARE_BAYTRAIL=y
CONFIG_I2C_DESIGNWARE_PCI=m
CONFIG_I2C_KEMPLD=m
@@ -891,11 +898,13 @@ CONFIG_VIDEO_TM6000_DVB=m
CONFIG_MFD_AXP20X_I2C=m
# CONFIG_MFD_INTEL_QUARK_I2C_GPIO is not set
CONFIG_LPC_ICH=m
+CONFIG_INTEL_SOC_PMIC=y
CONFIG_INTEL_SOC_PMIC_BXTWC=m
CONFIG_INTEL_SOC_PMIC_CHTWC=y
CONFIG_INTEL_SOC_PMIC_CHTDC_TI=m
CONFIG_MFD_INTEL_LPSS_ACPI=m
CONFIG_MFD_INTEL_LPSS_PCI=m
+CONFIG_MFD_INTEL_PMC_BXT=m
CONFIG_MFD_KEMPLD=m
CONFIG_MFD_MENF21BMC=m
@@ -1347,6 +1356,7 @@ CONFIG_ALIENWARE_WMI=m
CONFIG_HUAWEI_WMI=m
CONFIG_INTEL_WMI_THUNDERBOLT=m
CONFIG_PEAQ_WMI=m
+CONFIG_XIAOMI_WMI=m
CONFIG_ACERHDF=m
CONFIG_ACER_WIRELESS=m
CONFIG_ACER_WMI=m
@@ -1397,6 +1407,7 @@ CONFIG_SURFACE_3_BUTTON=m
CONFIG_SURFACE_PRO3_BUTTON=m
CONFIG_MSI_LAPTOP=m
CONFIG_MSI_WMI=m
+CONFIG_PCENGINES_APU2=m
CONFIG_SAMSUNG_LAPTOP=m
CONFIG_SAMSUNG_Q10=m
CONFIG_ACPI_TOSHIBA=m
@@ -1745,12 +1756,22 @@ CONFIG_USB_SL811_HCD=m
CONFIG_USB_SL811_CS=m
##
+## file: drivers/usb/roles/Kconfig
+##
+CONFIG_USB_ROLES_INTEL_XHCI=m
+
+##
## file: drivers/usb/typec/Kconfig
##
CONFIG_TYPEC=m
CONFIG_TYPEC_TPS6598X=m
##
+## file: drivers/usb/typec/mux/Kconfig
+##
+CONFIG_TYPEC_MUX_PI3USB30532=m
+
+##
## file: drivers/usb/typec/tcpm/Kconfig
##
CONFIG_TYPEC_TCPM=m
diff --git a/debian/copyright b/debian/copyright
index 857d7cda15e1..e93b6f4f99fe 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -192,6 +192,37 @@ Copyright: 2014-2015 Red Hat, Inc.
2015 Intel Corporation
License: LGPL-2.1
+Files: tools/lib/bpf/*
+Copyright: 2015-2020 Linus Torvalds and many others
+License: LGPL-2.1 or BSD-2-clause
+
+Files: tools/bpf/bpftool/*
+Copyright: 2017-2020 Linus Torvalds and many others
+License: GPL-2 or BSD-2-clause
+
+License: BSD-2-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are met:
+ .
+ 1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ .
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+ LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ POSSIBILITY OF SUCH DAMAGE.
+
License: GPL-2
This package is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License version 2 as
diff --git a/debian/patches/bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch b/debian/patches/bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch
new file mode 100644
index 000000000000..6d0b93d2fbe6
--- /dev/null
+++ b/debian/patches/bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch
@@ -0,0 +1,30 @@
+From: Ben Hutchings <benh@debian.org>
+Date: Fri, 14 Aug 2020 00:43:54 +0100
+Subject: bpftool: Fix version string in recursive builds
+Forwarded: https://lore.kernel.org/bpf/20200813235837.GA497088@decadent.org.uk/T/#u
+
+When bpftool is built as part of a Debian package build, which itself
+uses make, "bpftool version" shows:
+
+ bpftool vmake[4]: Entering directory /build/linux-5.8/tools/bpf/bpftool 5.8.8.0 make[4]: Leaving directory /build/linux-5.8
+
+Although we pass the "--no-print-directory" option, this is overridden
+by the environment variable "MAKEFLAGS=w". Clear MAKEFLAGS for the
+"make kernelversion" command.
+
+I have no explanation for the doubled ".8" in the version string, but
+this seems to fix that as well.
+
+Signed-off-by: Ben Hutchings <benh@debian.org>
+---
+--- a/tools/bpf/bpftool/Makefile
++++ b/tools/bpf/bpftool/Makefile
+@@ -25,7 +25,7 @@ endif
+
+ LIBBPF = $(LIBBPF_PATH)libbpf.a
+
+-BPFTOOL_VERSION := $(shell make -rR --no-print-directory -sC ../../.. kernelversion)
++BPFTOOL_VERSION := $(shell MAKEFLAGS= make -rR --no-print-directory -sC ../../.. kernelversion)
+
+ $(LIBBPF): FORCE
+ $(if $(LIBBPF_OUTPUT),@mkdir -p $(LIBBPF_OUTPUT))
diff --git a/debian/patches/series b/debian/patches/series
index b5e440b016ec..3c4a7f5984c4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -124,6 +124,7 @@ bugfix/all/libcpupower-hide-private-function.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch
bugfix/all/0005-libtraceevent-Add-dependency-on-libdl.patch
+bugfix/all/bpftool-fix-version-string-in-recursive-builds.patch
# overlay: allow mounting in user namespaces
debian/overlayfs-permit-mounts-in-userns.patch
diff --git a/debian/rules.d/tools/bpf/bpftool/Makefile b/debian/rules.d/tools/bpf/bpftool/Makefile
new file mode 100644
index 000000000000..70447d449df4
--- /dev/null
+++ b/debian/rules.d/tools/bpf/bpftool/Makefile
@@ -0,0 +1,29 @@
+include $(top_rulesdir)/Makefile.inc
+
+MAKE_BPFTOOL := +$(MAKE) -C $(top_srcdir)/$(OUTDIR) O=$(CURDIR)
+MAKE_BPFTOOL += prefix=/usr
+MAKE_BPFTOOL += mandir=/usr/share/man
+MAKE_BPFTOOL += V=$(KBUILD_VERBOSE)
+MAKE_BPFTOOL += ARCH=$(KERNEL_ARCH)
+
+# dynamically linking with libbfd is not allowed in Debian
+MAKE_BPFTOOL += feature-libbfd=0 feature-libbfd-liberty=0 feature-libbfd-liberty-z=0
+
+all:
+ $(MAKE_BPFTOOL)
+ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+ $(MAKE_BPFTOOL) doc
+endif
+# Check that bpftool wasn't linked with libbfd
+ type ldd
+ ! ldd $(CURDIR)/bpftool | grep -E '\blibbfd'
+
+install:
+ $(MAKE_BPFTOOL) install
+ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+ $(MAKE_BPFTOOL) doc-install
+# doc-install installs a bpf-helpers.7 that conflicts
+# with the one distributed by the manpages package.
+ rm $(DESTDIR)/usr/share/man/man7/bpf-helpers.7
+ rmdir $(DESTDIR)/usr/share/man/man7/
+endif
diff --git a/debian/rules.real b/debian/rules.real
index d1adba71ff92..d527f131f9d0 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -63,6 +63,7 @@ build-arch-arch: \
$(call if_package, linux-kbuild-$(VERSION), build-kbuild) \
$(call if_package, linux-perf-$(VERSION), build-perf) \
$(call if_package, linux-bootwrapper-$(ABINAME), build-bootwrapper) \
+ $(call if_package, bpftool, build-bpftool) \
$(call if_package, usbip, build-usbip) \
$(call if_package, linux-cpupower, build-cpupower) \
$(call if_package, liblockdep-dev, build-liblockdep) \
@@ -76,6 +77,7 @@ binary-arch-arch: \
$(if $(filter-out x-$(VERSION),x$(SOURCE_SUFFIX)), \
$(call if_package, linux-perf$(SOURCE_SUFFIX), install-perf-meta)) \
$(call if_package, linux-bootwrapper-$(ABINAME), install-bootwrapper) \
+ $(call if_package, bpftool, install-bpftool) \
$(call if_package, usbip, install-usbip) \
$(call if_package, linux-cpupower, install-cpupower) \
$(call if_package, liblockdep-dev, install-liblockdep) \
@@ -622,6 +624,31 @@ $(STAMPS_DIR)/build-tools-headers:
headers_install
@$(stamp)
+build-bpftool: $(STAMPS_DIR)/build-tools-headers
+ $(call make-tools,tools/bpf/bpftool)
+
+install-bpftool: PACKAGE_NAME = bpftool
+install-bpftool: DH_OPTIONS = -p$(PACKAGE_NAME)
+install-bpftool: DIR = $(CURDIR)/debian/$(PACKAGE_NAME)
+install-bpftool: build-bpftool
+ dh_testdir
+ dh_testroot
+ dh_prep
+ $(call make-tools,tools/bpf/bpftool) install DESTDIR=$(DIR)
+ dh_installchangelogs
+ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+ dh_installdocs
+endif
+ dh_lintian
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
build-kbuild: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,scripts)
$(call make-tools,tools/objtool)
diff --git a/debian/templates/control.libc-dev.in b/debian/templates/control.libc-dev.in
index c62fa3c3f334..e66513ea9221 100644
--- a/debian/templates/control.libc-dev.in
+++ b/debian/templates/control.libc-dev.in
@@ -1,9 +1,6 @@
Package: linux-libc-dev
Section: devel
Depends: ${misc:Depends}
-# Remove this Provides when nothing Depends/Build-Depends/B-D-Arch on it.
-# See bug #959462.
-Provides: linux-kernel-headers
Multi-Arch: same
Description: Linux support headers for userspace development
This package provides userspaces headers from the Linux kernel. These headers
diff --git a/debian/templates/control.tools-unversioned.in b/debian/templates/control.tools-unversioned.in
index e8a2a018c90c..3d76f9a7dbbe 100644
--- a/debian/templates/control.tools-unversioned.in
+++ b/debian/templates/control.tools-unversioned.in
@@ -1,3 +1,16 @@
+Package: bpftool
+Build-Profiles: <!stage1 !pkg.linux.notools>
+Section: devel
+Architecture: linux-any
+Build-Depends:
+ python3-docutils <!stage1 !nodoc !pkg.linux.notools>,
+ libelf-dev,
+ zlib1g-dev,
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Inspection and simple manipulation of BPF programs and maps
+ The bpftool command allows for inspection and simple modification of
+ Berkeley Packet Filter (BPF) objects on the system.
+
Package: linux-cpupower
Build-Profiles: <!stage1 !pkg.linux.notools>
Section: admin