aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/hyperv-daemons.hv-fcopy-daemon.init4
-rwxr-xr-xdebian/hyperv-daemons.hv-kvp-daemon.init4
-rwxr-xr-xdebian/hyperv-daemons.hv-vss-daemon.init4
4 files changed, 9 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c3a439efe16..62b5fc218a81 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -35,6 +35,9 @@ linux (5.8-1~exp1) UNRELEASED; urgency=medium
* [cloud] Disable DLM, GFS2_FS, OCFS2_FS.
* Move System.map into debug package and replace with pointer.
+ [ Ben Hutchings ]
+ * [x86] hyperv-daemons: Complete renaming of init scripts
+
-- Yves-Alexis Perez <corsac@debian.org> Wed, 24 Jun 2020 21:58:24 +0200
linux (5.7.10-1) unstable; urgency=medium
diff --git a/debian/hyperv-daemons.hv-fcopy-daemon.init b/debian/hyperv-daemons.hv-fcopy-daemon.init
index aa124bb78bbd..5866dc60edce 100755
--- a/debian/hyperv-daemons.hv-fcopy-daemon.init
+++ b/debian/hyperv-daemons.hv-fcopy-daemon.init
@@ -1,6 +1,6 @@
#! /bin/sh
### BEGIN INIT INFO
-# Provides: hyperv-daemons.hv-fcopy-daemon
+# Provides: hv-fcopy-daemon
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
@@ -13,7 +13,7 @@ DESC="Hyper-V file copy service (FCOPY) daemon"
NAME=hv_fcopy_daemon
DAEMON=/usr/sbin/$NAME
PIDFILE=/run/$NAME.pid
-SCRIPTNAME=/etc/init.d/hyperv-daemons.hv-fcopy-daemon
+SCRIPTNAME=/etc/init.d/hv-fcopy-daemon
# Exit if the package is not installed
[ -x "$DAEMON" ] || exit 0
diff --git a/debian/hyperv-daemons.hv-kvp-daemon.init b/debian/hyperv-daemons.hv-kvp-daemon.init
index a03b02f108bb..6a78f478b2dc 100755
--- a/debian/hyperv-daemons.hv-kvp-daemon.init
+++ b/debian/hyperv-daemons.hv-kvp-daemon.init
@@ -1,6 +1,6 @@
#! /bin/sh
### BEGIN INIT INFO
-# Provides: hyperv-daemons.hv-kvp-daemon
+# Provides: hv-kvp-daemon
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
@@ -13,7 +13,7 @@ DESC="Hyper-V key-value pair (KVP) daemon"
NAME=hv_kvp_daemon
DAEMON=/usr/sbin/$NAME
PIDFILE=/run/$NAME.pid
-SCRIPTNAME=/etc/init.d/hyperv-daemons.hv-kvp-daemon
+SCRIPTNAME=/etc/init.d/hv-kvp-daemon
# Exit if the package is not installed
[ -x "$DAEMON" ] || exit 0
diff --git a/debian/hyperv-daemons.hv-vss-daemon.init b/debian/hyperv-daemons.hv-vss-daemon.init
index aa899b132b0a..31831aabe404 100755
--- a/debian/hyperv-daemons.hv-vss-daemon.init
+++ b/debian/hyperv-daemons.hv-vss-daemon.init
@@ -1,6 +1,6 @@
#! /bin/sh
### BEGIN INIT INFO
-# Provides: hyperv-daemons.hv-vss-daemon
+# Provides: hv-vss-daemon
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
@@ -13,7 +13,7 @@ DESC="Hyper-V volume shadow copy service (VSS) daemon"
NAME=hv_vss_daemon
DAEMON=/usr/sbin/$NAME
PIDFILE=/run/$NAME.pid
-SCRIPTNAME=/etc/init.d/hyperv-daemons.hv-vss-daemon
+SCRIPTNAME=/etc/init.d/hv-vss-daemon
# Exit if the package is not installed
[ -x "$DAEMON" ] || exit 0