aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/bin/test-patches2
-rw-r--r--debian/changelog2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/bin/test-patches b/debian/bin/test-patches
index 7baf26e23bb9..6cf9bfcb3775 100755
--- a/debian/bin/test-patches
+++ b/debian/bin/test-patches
@@ -52,7 +52,7 @@ dpkg-checkbuilddeps -B
version="$(dpkg-parsechangelog | sed 's/^Version: //; t; d')"
if [ "${version%a~test}" = "$version" ]; then
version="$version"a~test
- dch -v "$version" "Testing patches $*"
+ dch -v "$version" --distribution UNRELEASED "Testing patches $*"
fi
debversion="${version##*-}"
diff --git a/debian/changelog b/debian/changelog
index 9622d02ca731..66ab9295d2ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -43,6 +43,8 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
- inotify: do not reuse watch descriptors (Closes: #561880)
- megaraid_sas: remove sysfs poll_mode_io world writeable permissions
(CVE-2009-3939) (Closes: #562975)
+ * Force distribution=UNRELEASED in debian/bin/test-patches so that it
+ works in released source packages
[ Ian Campbell ]
* xen: Enable up to 32G of guest memory on i386.