aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/advansys_fdomain-pci-id-table.patch55
-rw-r--r--debian/patches/series/61
3 files changed, 58 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bb809056adbf..805ca4703310 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ linux-2.6 (2.6.17-6) UNRELEASED; urgency=low
[ maximilian attems ]
* debian/arch/i386/defines: Activate 686-bigmem flavour for enterprise
usage.
+ * Add ubuntu pci table patch for scsi drivers advansys and fdomain.
[ Martin Michlmayr ]
* arm/armeb: Use gcc-4.1.
@@ -46,7 +47,7 @@ linux-2.6 (2.6.17-6) UNRELEASED; urgency=low
- Don't allow chmod() on the /proc/<pid>/ files
- PCI: fix issues with extended conf space when MMCONFIG disabled because of e820
- -- Frederik Schüler <fs@debian.org> Mon, 7 Aug 2006 13:00:02 +0200
+ -- maximilian attems <maks@sternwelten.at> Tue, 8 Aug 2006 09:50:28 +0200
linux-2.6 (2.6.17-5) unstable; urgency=low
diff --git a/debian/patches/advansys_fdomain-pci-id-table.patch b/debian/patches/advansys_fdomain-pci-id-table.patch
new file mode 100644
index 000000000000..14ed1e1507b3
--- /dev/null
+++ b/debian/patches/advansys_fdomain-pci-id-table.patch
@@ -0,0 +1,55 @@
+From: Ben Collins <bcollins@ubuntu.com>
+Date: Fri, 11 Nov 2005 20:01:26 +0000 (-0500)
+Subject: [UBUNTU:scsi] Add basic hotplug support to some drivers
+X-Git-Tag: v2.6.15-rc1
+X-Git-Url: http://kernel.org/git/?p=linux/kernel/git/bcollins/ubuntu-2.6.git;a=commitdiff;h=e82633eb19c4b390846a6eecd72204b696448954
+
+[UBUNTU:scsi] Add basic hotplug support to some drivers
+
+PatchAuthor: Unknown
+UpstreamStatus: Unsubmitted
+
+Signed-off-by: Ben Collins <bcollins@ubuntu.com>
+---
+
+--- a/drivers/scsi/advansys.c
++++ b/drivers/scsi/advansys.c
+@@ -18226,3 +18226,20 @@ AdvInquiryHandling(
+ }
+ }
+ MODULE_LICENSE("Dual BSD/GPL");
++
++static struct pci_device_id advansys_pci_tbl[] __devinitdata = {
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_1100,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_1200,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_1300,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_2300,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_2500,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { ASC_PCI_VENDORID, ASC_PCI_DEVICE_ID_2700,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { }
++};
++MODULE_DEVICE_TABLE(pci, advansys_pci_tbl);
+--- a/drivers/scsi/fdomain.c
++++ b/drivers/scsi/fdomain.c
+@@ -1720,6 +1720,15 @@ static int fdomain_16x0_release(struct S
+ return 0;
+ }
+
++#ifndef PCMCIA
++static struct pci_device_id fdomain_pci_tbl[] __devinitdata = {
++ { PCI_VENDOR_ID_FD, PCI_DEVICE_ID_FD_36C70,
++ PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
++ { }
++};
++MODULE_DEVICE_TABLE(pci, fdomain_pci_tbl);
++#endif
++
+ struct scsi_host_template fdomain_driver_template = {
+ .module = THIS_MODULE,
+ .name = "fdomain",
diff --git a/debian/patches/series/6 b/debian/patches/series/6
index d9c77c3c9a6b..ffcc3bea2fbe 100644
--- a/debian/patches/series/6
+++ b/debian/patches/series/6
@@ -1,2 +1,3 @@
- budget-av-compile-fix.patch
+ 2.6.17.8
++ advansys_fdomain-pci-id-table.patch