aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2019-01-18 20:18:54 +0000
committerBen Hutchings <ben@decadent.org.uk>2019-01-18 23:54:28 +0000
commitcd07c2e48b49b2479b7803916747f5e8b27645d5 (patch)
tree76c9d979ea08e6d71bd3ecbcee2f8e7d6c603a84 /debian/rules.real
parentf75cc1f217eccca641ed6af64ab676e167bddd69 (diff)
downloadkernel_replicant_linux-cd07c2e48b49b2479b7803916747f5e8b27645d5.tar.gz
kernel_replicant_linux-cd07c2e48b49b2479b7803916747f5e8b27645d5.tar.bz2
kernel_replicant_linux-cd07c2e48b49b2479b7803916747f5e8b27645d5.zip
debian/rules.d, debian/rules.real: Restore build of userland headers for tools
Since commit f5f169ba999c "Split build rules for tools to allow skipping them." debian/rules.d/Makefile is not used and the current kernel's UAPI headers are not installed. This hasn't caused breakage yet, probably because many tools have their own workaround using include/uapi etc. directly, but could break backports builds at some point. Move the build of userland headers up into debian/rules.real and make all tools build targets depend on it.
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real23
1 files changed, 15 insertions, 8 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 16e777b3111e..ef860dc93d55 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -596,7 +596,14 @@ define make-tools
+mkdir -p $(BUILD_DIR)/build-tools/$(1) && $(MAKE_CLEAN) -C $(BUILD_DIR)/build-tools/$(1) -f $(CURDIR)/debian/rules.d/$(1)/Makefile top_srcdir=$(CURDIR) top_rulesdir=$(CURDIR)/debian/rules.d OUTDIR=$(1) VERSION=$(VERSION) KERNEL_ARCH=$(KERNEL_ARCH)
endef
-build-kbuild:
+$(STAMPS_DIR)/build-tools-headers:
+ mkdir -p $(BUILD_DIR)/build-tools/headers-tools
+ $(MAKE) ARCH=$(KERNEL_ARCH) O=$(BUILD_DIR)/build-tools/headers-tools \
+ INSTALL_HDR_PATH=$(CURDIR)/$(BUILD_DIR)/build-tools \
+ headers_install
+ @$(stamp)
+
+build-kbuild: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,scripts)
$(call make-tools,tools/objtool)
@@ -624,7 +631,7 @@ endif
dh_md5sums
dh_builddeb
-build-cpupower:
+build-cpupower: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/power/cpupower)
ifneq ($(filter i386 amd64 x32,$(DEB_HOST_ARCH)),)
$(call make-tools,tools/power/x86)
@@ -664,7 +671,7 @@ endif
dh_md5sums
dh_builddeb
-build-perf:
+build-perf: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/perf)
install-perf: PACKAGE_NAME = linux-perf-$(VERSION)
@@ -693,7 +700,7 @@ endif
dh_md5sums
dh_builddeb
-build-usbip:
+build-usbip: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/usb/usbip)
install-usbip: DH_OPTIONS = -pusbip
@@ -721,7 +728,7 @@ endif
dh_md5sums
dh_builddeb
-build-hyperv-daemons:
+build-hyperv-daemons: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/hv)
install-hyperv-daemons: PACKAGE_NAME = hyperv-daemons
@@ -759,7 +766,7 @@ endif
dh_md5sums
dh_builddeb
-build-libbpf:
+build-libbpf: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/lib/bpf)
install-libbpf: DH_OPTIONS = -plibbpf$(VERSION) -plibbpf-dev
@@ -787,7 +794,7 @@ endif
dh_md5sums
dh_builddeb
-build-liblockdep:
+build-liblockdep: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,tools/lib/lockdep)
install-liblockdep: DH_OPTIONS = -pliblockdep$(VERSION) -pliblockdep-dev
@@ -838,7 +845,7 @@ endif
dh_md5sums
dh_builddeb
-build-bootwrapper:
+build-bootwrapper: $(STAMPS_DIR)/build-tools-headers
$(call make-tools,arch/powerpc/boot)
install-bootwrapper: PACKAGE_NAME = linux-bootwrapper-$(ABINAME)