aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2010-02-04 11:09:53 +0000
committerBastian Blank <waldi@debian.org>2010-02-04 11:09:53 +0000
commit65ee02f46b39ed07bf212a368fd4f1660d289841 (patch)
treea9f069d7643d986d1a4db07031e7fd96ab693cb8 /debian/rules.real
parentb03ba34bc98b4d1fe1a489ac1e418adc5e622bc0 (diff)
downloadkernel_replicant_linux-65ee02f46b39ed07bf212a368fd4f1660d289841.tar.gz
kernel_replicant_linux-65ee02f46b39ed07bf212a368fd4f1660d289841.tar.bz2
kernel_replicant_linux-65ee02f46b39ed07bf212a368fd4f1660d289841.zip
Don't let default compiler flags escape into the build.
* debian/changelog: Update. * debian/bin/gencontrol.py: Rename CFLAGS to CFLAGS_KERNEL. * debian/rules.real: Use CFLAGS_KERNEL. svn path=/dists/trunk/linux-2.6/; revision=15119
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules.real b/debian/rules.real
index c02d42a1ffe6..3c014820b2d9 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -111,8 +111,8 @@ else
echo 'override CROSS_COMPILE = $$(DEB_HOST_GNU_TYPE)-' >> '$(DIR)/.kernelvariables'
echo 'endif' >> '$(DIR)/.kernelvariables'
endif
-ifdef CFLAGS
- echo 'CFLAGS += $(CFLAGS)' >> '$(DIR)/.kernelvariables'
+ifdef CFLAGS_KERNEL
+ echo 'CFLAGS += $(CFLAGS_KERNEL)' >> '$(DIR)/.kernelvariables'
endif
+$(MAKE_CLEAN) -C '$(SOURCE_DIR)' O='$(CURDIR)/$(DIR)' reportoldconfig
+$(MAKE_CLEAN) -C '$(SOURCE_DIR)' O='$(CURDIR)/$(DIR)' $(JOBS_ARG) prepare