aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2020-01-01 20:38:53 +0100
committerSalvatore Bonaccorso <carnil@debian.org>2020-01-01 20:40:59 +0100
commit33639568475c399acc9cd9d45e9b06a3a2df6e75 (patch)
tree9018e0e276de4555b82dbb4ffe703ba0d60a17f9
parent5d23c6e59642f9d9e64c74fb2fbdebb23b2e3751 (diff)
downloadkernel_replicant_linux-33639568475c399acc9cd9d45e9b06a3a2df6e75.tar.gz
kernel_replicant_linux-33639568475c399acc9cd9d45e9b06a3a2df6e75.tar.bz2
kernel_replicant_linux-33639568475c399acc9cd9d45e9b06a3a2df6e75.zip
Enable EROFS filesystem support as module
Enable EROFS_FS as module, enable EROFS_FS_XATTR, EROFS_FS_POSIX_ACL, EROFS_FS_SECURITY, EROFS_FS_ZIP and EROFS_FS_CLUSTER_PAGE_LIMIT. Closes: #946569 Thanks: Gao Xiang <gaoxiang25@huawei.com>
-rw-r--r--debian/changelog4
-rw-r--r--debian/config/config11
2 files changed, 15 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b790770e032a..4aab340afa32 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -315,6 +315,10 @@ linux (5.4.7-1) UNRELEASED; urgency=medium
* [rt] Refresh lib-ubsan-Don-t-seralize-UBSAN-report.patch for context
changes in 5.4.7
* [rt] Drop x86-ioapic-Prevent-inconsistent-state-when-moving-an.patch
+ * Enable EROFS filesystem support as module.
+ Enable EROFS_FS as module, enable EROFS_FS_XATTR, EROFS_FS_POSIX_ACL,
+ EROFS_FS_SECURITY, EROFS_FS_ZIP and EROFS_FS_CLUSTER_PAGE_LIMIT.
+ Thanks to Gao Xiang <gaoxiang25@huawei.com> (Closes: #946569)
[ YunQiang Su ]
* [mips*/octeon] Fix ftbfs on mips* due to octeon image-file:
diff --git a/debian/config/config b/debian/config/config
index 17a2059e5180..cb782f86a7ed 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -5815,6 +5815,17 @@ CONFIG_EFIVAR_FS=m
CONFIG_EFS_FS=m
##
+## file: fs/erofs/Kconfig
+##
+CONFIG_EROFS_FS=m
+# CONFIG_EROFS_FS_DEBUG is not set
+CONFIG_EROFS_FS_XATTR=y
+CONFIG_EROFS_FS_POSIX_ACL=y
+CONFIG_EROFS_FS_SECURITY=y
+CONFIG_EROFS_FS_ZIP=y
+CONFIG_EROFS_FS_CLUSTER_PAGE_LIMIT=1
+
+##
## file: fs/ext2/Kconfig
##
# CONFIG_EXT2_FS is not set