aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSudip Mukherjee <sudipm.mukherjee@gmail.com>2019-12-07 12:12:22 +0000
committerSudip Mukherjee <sudipm.mukherjee@gmail.com>2019-12-26 22:55:29 +0000
commitd2d026c97188d09e74e10c82fa3eea245494639d (patch)
tree02eabfd3a0cc3c3bfd2485bdca6dfbaf0d93bf31
parent4411fc59508250597ca79bb7e1889ab3f8af21f6 (diff)
downloadkernel_replicant_linux-d2d026c97188d09e74e10c82fa3eea245494639d.tar.gz
kernel_replicant_linux-d2d026c97188d09e74e10c82fa3eea245494639d.tar.bz2
kernel_replicant_linux-d2d026c97188d09e74e10c82fa3eea245494639d.zip
libtraceevent: Add makefile
Add the makefile to build libtracevent in debian. rules file will use this Makefile. Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
-rw-r--r--debian/rules.d/tools/lib/traceevent/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules.d/tools/lib/traceevent/Makefile b/debian/rules.d/tools/lib/traceevent/Makefile
new file mode 100644
index 000000000000..93620398b97a
--- /dev/null
+++ b/debian/rules.d/tools/lib/traceevent/Makefile
@@ -0,0 +1,23 @@
+include $(top_rulesdir)/Makefile.inc
+
+DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+# Catch use of missing kernel APIs early
+CFLAGS += -Werror=implicit-function-declaration
+
+# Don't let the kernel version override traceevent's version
+undefine VERSION
+PREFIX=/usr
+
+MAKE_TRACEEVENT := +$(MAKE) -C $(top_srcdir)/$(OUTDIR) O=$(CURDIR)
+MAKE_TRACEEVENT += prefix=$(PREFIX)
+MAKE_TRACEEVENT += libdir_relative=lib/$(DEB_HOST_MULTIARCH)
+MAKE_TRACEEVENT += pkgconfig_dir=$(PREFIX)/lib/$(DEB_HOST_MULTIARCH)/pkgconfig
+MAKE_TRACEEVENT += V=$(KBUILD_VERBOSE)
+MAKE_TRACEEVENT += ARCH=$(KERNEL_ARCH)
+
+all:
+ $(MAKE_TRACEEVENT)
+
+install:
+ $(MAKE_TRACEEVENT) install