aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Richey <joerichey@google.com>2019-12-05 17:46:17 -0800
committerJoe Richey <joerichey@google.com>2019-12-17 15:51:54 -0800
commitca4ccd87d3dd8715183c00efe2e16e51188c8503 (patch)
treec938134ef5eb1c09cd15f4b3b9907bd13ba751af
parentb7ccfb603dc681e4b6c8a9ed5f6c8e3c95334be3 (diff)
downloadkernel_replicant_linux-ca4ccd87d3dd8715183c00efe2e16e51188c8503.tar.gz
kernel_replicant_linux-ca4ccd87d3dd8715183c00efe2e16e51188c8503.tar.bz2
kernel_replicant_linux-ca4ccd87d3dd8715183c00efe2e16e51188c8503.zip
[cloud-amd64] tpm: Enable TPM drivers for Cloud (Closes: #946237)
The bug has most of the context for this fix. Basically, the cloud image disables TPM drives, and we want to reenable them. I added the virt and hardware-agnostic drivers (TIS/CRB/XEN/VTPM), and I explictly didn't add the hardware-specific drivers. I also didn't bother with CONFIG_HW_RANDOM_TPM as we already set CONFIG_RANDOM_TRUST_CPU=y which handles any early-boot RNG issues. Signed-off-by: Joe Richey <joerichey@google.com>
-rw-r--r--debian/changelog3
-rw-r--r--debian/config/amd64/config.cloud-amd6414
2 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5612d9d32fe5..11c3b0119a3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -247,6 +247,9 @@ linux (5.4.4-1~exp1) UNRELEASED; urgency=medium
- workqueue: Fix missing kfree(rescuer) in destroy_workqueue()
- r8169: fix rtl_hw_jumbo_disable for RTL8168evl
+ [ Joe Richey ]
+ * [cloud-amd64] tpm: Enable TPM drivers for Cloud (Closes: #946237)
+
[ Ben Hutchings ]
* [armel/rpi,armhf,arm64] Enable DEBUG_WX
diff --git a/debian/config/amd64/config.cloud-amd64 b/debian/config/amd64/config.cloud-amd64
index b71225db1971..26002df08717 100644
--- a/debian/config/amd64/config.cloud-amd64
+++ b/debian/config/amd64/config.cloud-amd64
@@ -176,7 +176,19 @@ CONFIG_XEN_BLKDEV_FRONTEND=m
##
## file: drivers/char/tpm/Kconfig
##
-# CONFIG_TCG_TPM is not set
+CONFIG_TCG_TPM=m
+# CONFIG_HW_RANDOM_TPM is not set
+CONFIG_TCG_TIS=m
+# CONFIG_TCG_TIS_SPI is not set
+# CONFIG_TCG_TIS_I2C_ATMEL is not set
+# CONFIG_TCG_TIS_I2C_INFINEON is not set
+# CONFIG_TCG_TIS_I2C_NUVOTON is not set
+# CONFIG_TCG_NSC is not set
+# CONFIG_TCG_ATMEL is not set
+# CONFIG_TCG_INFINEON is not set
+CONFIG_TCG_XEN=m
+CONFIG_TCG_CRB=m
+CONFIG_TCG_VTPM_PROXY=m
##
## file: drivers/char/xillybus/Kconfig