aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYunQiang Su <syq@debian.org>2019-12-19 03:39:31 -0800
committerYunQiang Su <syq@debian.org>2019-12-19 04:16:17 -0800
commitb1d08a0cffbe181cbb94e3fc72a91c2e8a8a38e7 (patch)
treee0b6f8b685086a9ae6a8ac3e182ffdf3f7af9162
parent1d0a6dba5ee2df48ea09e4fc3378c9b241356988 (diff)
downloadkernel_replicant_linux-b1d08a0cffbe181cbb94e3fc72a91c2e8a8a38e7.tar.gz
kernel_replicant_linux-b1d08a0cffbe181cbb94e3fc72a91c2e8a8a38e7.tar.bz2
kernel_replicant_linux-b1d08a0cffbe181cbb94e3fc72a91c2e8a8a38e7.zip
mips: enable O32_FP64 and MSA
CONFIG_MIPS_O32_FP64_SUPPORT is required to support MSA for O32. It requires CPU >= mips32r1. It is OK for us: currently our baseline is mips32r2/mips64r2. Malta can use different CPUs, some of them may support MSA. Loongson 3A/B 4000 will support MSA. The only CPU currently we support has no MSA is octeon.
-rw-r--r--debian/changelog2
-rw-r--r--debian/config/kernelarch-mips/config2
-rw-r--r--debian/config/kernelarch-mips/config.boston1
-rw-r--r--debian/config/kernelarch-mips/config.octeon1
4 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bb6b90f5adc0..136277ad3c5e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -292,6 +292,8 @@ linux (5.4.5-1~exp1) UNRELEASED; urgency=medium
[ YunQiang Su ]
* [mipsel,mips64el/loongson-3] Enable AMDGPU.
* [mips*] switch to vmlinuz from vmlinux except octeon.
+ * [mips*] enable CONFIG_MIPS_O32_FP64_SUPPORT.
+ * [mips*] enable CONFIG_CPU_HAS_MSA except octeon.
-- Ben Hutchings <ben@decadent.org.uk> Thu, 05 Dec 2019 17:31:13 +0000
diff --git a/debian/config/kernelarch-mips/config b/debian/config/kernelarch-mips/config
index 3ca806257175..c52301bcd4e2 100644
--- a/debian/config/kernelarch-mips/config
+++ b/debian/config/kernelarch-mips/config
@@ -1,11 +1,13 @@
##
## file: arch/mips/Kconfig
##
+CONFIG_CPU_HAS_MSA=y
CONFIG_RELOCATABLE=y
CONFIG_RELOCATION_TABLE_SIZE=0x00140000
CONFIG_RANDOMIZE_BASE=y
CONFIG_KEXEC=y
CONFIG_SECCOMP=y
+CONFIG_MIPS_O32_FP64_SUPPORT=y
#. Ignored in 32-bit configurations
CONFIG_MIPS32_O32=y
CONFIG_MIPS32_N32=y
diff --git a/debian/config/kernelarch-mips/config.boston b/debian/config/kernelarch-mips/config.boston
index ef96201f230a..20178e1503af 100644
--- a/debian/config/kernelarch-mips/config.boston
+++ b/debian/config/kernelarch-mips/config.boston
@@ -5,7 +5,6 @@
CONFIG_MIPS_GENERIC=y
## end choice
CONFIG_MIPS_CPS=y
-CONFIG_CPU_HAS_MSA=y
CONFIG_HIGHMEM=y
CONFIG_NR_CPUS=16
diff --git a/debian/config/kernelarch-mips/config.octeon b/debian/config/kernelarch-mips/config.octeon
index 7b05c4ba4530..dbd98f0b5777 100644
--- a/debian/config/kernelarch-mips/config.octeon
+++ b/debian/config/kernelarch-mips/config.octeon
@@ -8,6 +8,7 @@ CONFIG_CAVIUM_OCTEON_SOC=y
# CONFIG_32BIT is not set
CONFIG_64BIT=y
## end choice
+# CONFIG_CPU_HAS_MSA is not set
CONFIG_SMP=y
# CONFIG_HOTPLUG_CPU is not set
CONFIG_NR_CPUS=64