aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-10-13 09:16:05 +0000
committerSalvatore Bonaccorso <carnil@debian.org>2021-10-13 09:16:05 +0000
commit974fa0f97a26aeef74ea2928f32554dc64ff4239 (patch)
tree250d0345b7a2f556d848c5b3f24b114d84f82622
parent8aa0e07e7f85ad350a3710de3e2340ffccf6c571 (diff)
parent15a234eeef9067239809c680f5bb7ece371532ef (diff)
downloadkernel_replicant_linux-974fa0f97a26aeef74ea2928f32554dc64ff4239.tar.gz
kernel_replicant_linux-974fa0f97a26aeef74ea2928f32554dc64ff4239.tar.bz2
kernel_replicant_linux-974fa0f97a26aeef74ea2928f32554dc64ff4239.zip
Merge branch 'benh/warnings-fixes' into 'sid'
Fix build warnings See merge request kernel-team/linux!409
-rw-r--r--debian/changelog4
-rw-r--r--debian/libcpupower1.symbols2
-rw-r--r--debian/patches/bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch10
-rw-r--r--debian/rules.real1
4 files changed, 11 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index a1c387a0481d..f5fd2d305823 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,10 @@ linux (5.14.9-3) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* debian/.gitignore: Ignore debian/tests/control again
* integrity: Drop "MODSIGN: load blacklist from MOKx" as redundant after 5.13
+ * tools/perf: Fix warning introduced by "tools/perf: pmu-events: Fix
+ reproducibility"
+ * debian/rules.real: Stop invoking obsolete headers_check target
+ * libcpupower: Update symbols file for changes in 5.13.9-1~exp1
-- Salvatore Bonaccorso <carnil@debian.org> Mon, 04 Oct 2021 22:05:09 +0200
diff --git a/debian/libcpupower1.symbols b/debian/libcpupower1.symbols
index 5639cbe8ab64..5e98bb32da39 100644
--- a/debian/libcpupower1.symbols
+++ b/debian/libcpupower1.symbols
@@ -37,4 +37,6 @@ libcpupower.so.1 libcpupower1 #MINVER#
cpuidle_state_time@Base 4.7~rc2-1~exp1
cpuidle_state_usage@Base 4.7~rc2-1~exp1
cpupower_is_cpu_online@Base 4.7~rc2-1~exp1
+ cpupower_read_sysfs@Base 5.13.9-1~exp1
+ cpupower_write_sysfs@Base 5.13.9-1~exp1
get_cpu_topology@Base 4.7~rc2-1~exp1
diff --git a/debian/patches/bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch b/debian/patches/bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch
index c0cf9b073ddb..f6deb46bf67c 100644
--- a/debian/patches/bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch
+++ b/debian/patches/bugfix/all/tools-perf-pmu-events-fix-reproducibility.patch
@@ -38,7 +38,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
int verbose;
char *prog;
-@@ -971,6 +983,78 @@
+@@ -971,6 +983,78 @@ static int get_maxfds(void)
*/
static FILE *eventsfp;
static char *mapfile;
@@ -109,7 +109,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+
+out:
+ for (i = 0; i < state.n; i++)
-+ free(state.entries[i].fpath);
++ free((char *)state.entries[i].fpath);
+ free(state.entries);;
+
+ return rc;
@@ -117,7 +117,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
static int is_leaf_dir(const char *fpath)
{
-@@ -1023,19 +1107,19 @@
+@@ -1023,19 +1107,19 @@ static int is_json_file(const char *name
return 0;
}
@@ -140,7 +140,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
int typeflag, struct FTW *ftwbuf)
{
char *tblname, *bname;
-@@ -1065,9 +1149,9 @@
+@@ -1065,9 +1149,9 @@ static int process_one_file(const char *
} else
bname = (char *) fpath + ftwbuf->base;
@@ -152,7 +152,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
/* base dir or too deep */
if (level == 0 || level > 4)
-@@ -1241,21 +1325,21 @@
+@@ -1241,21 +1325,21 @@ int main(int argc, char *argv[])
*/
maxfds = get_maxfds();
diff --git a/debian/rules.real b/debian/rules.real
index ee2f459bf9ef..e15b11a0b55d 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -377,7 +377,6 @@ install-libc-dev_$(ARCH):
dh_prep
rm -rf '$(DIR)'
mkdir -p $(DIR)
- +$(MAKE_CLEAN) O='$(CURDIR)/$(DIR)' headers_check ARCH=$(KERNEL_ARCH)
+$(MAKE_CLEAN) O='$(CURDIR)/$(DIR)' headers_install ARCH=$(KERNEL_ARCH) INSTALL_HDR_PATH='$(CURDIR)'/$(OUT_DIR)
rm -rf $(OUT_DIR)/include/drm $(OUT_DIR)/include/scsi