aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-03-19 16:54:04 +0100
committerSalvatore Bonaccorso <carnil@debian.org>2021-03-19 16:54:32 +0100
commit209c0029ea7df2f26ec76727b6fc0dec2e0c9052 (patch)
treee7a1666b62ed2a28663680efb7bcc9d68de06fb5
parent01ffd8e08fd317a977585d5ea6c38f6250bf350f (diff)
downloadkernel_replicant_linux-209c0029ea7df2f26ec76727b6fc0dec2e0c9052.tar.gz
kernel_replicant_linux-209c0029ea7df2f26ec76727b6fc0dec2e0c9052.tar.bz2
kernel_replicant_linux-209c0029ea7df2f26ec76727b6fc0dec2e0c9052.zip
Revert "nfsd4: remove check_conflicting_opens warning"
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/revert-nfsd4-remove-check_conflicting_opens-warning.patch31
-rw-r--r--debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 053f8e78279d..ec41e0f7590d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -889,6 +889,7 @@ linux (5.10.24-1) UNRELEASED; urgency=medium
* [x86] crypto: x86/aes-ni-xts - use direct calls to and 4-way stride
* RDMA/srp: Fix support for unpopulated and unbalanced NUMA nodes
* fuse: fix live lock in fuse_iget()
+ * Revert "nfsd4: remove check_conflicting_opens warning"
[ Wookey ]
* [arm64] drivers/perf: Enable ARM_CMN as module (Closes: #981186)
diff --git a/debian/patches/bugfix/all/revert-nfsd4-remove-check_conflicting_opens-warning.patch b/debian/patches/bugfix/all/revert-nfsd4-remove-check_conflicting_opens-warning.patch
new file mode 100644
index 000000000000..4825fda5d9e5
--- /dev/null
+++ b/debian/patches/bugfix/all/revert-nfsd4-remove-check_conflicting_opens-warning.patch
@@ -0,0 +1,31 @@
+From 4aa5e002034f0701c3335379fd6c22d7f3338cce Mon Sep 17 00:00:00 2001
+From: "J. Bruce Fields" <bfields@redhat.com>
+Date: Mon, 8 Mar 2021 10:51:51 -0500
+Subject: Revert "nfsd4: remove check_conflicting_opens warning"
+
+From: J. Bruce Fields <bfields@redhat.com>
+
+commit 4aa5e002034f0701c3335379fd6c22d7f3338cce upstream.
+
+This reverts commit 50747dd5e47b "nfsd4: remove check_conflicting_opens
+warning", as a prerequisite for reverting 94415b06eb8a, which has a
+serious bug.
+
+Cc: stable@vger.kernel.org
+Signed-off-by: J. Bruce Fields <bfields@redhat.com>
+Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+---
+ fs/nfsd/nfs4state.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/fs/nfsd/nfs4state.c
++++ b/fs/nfsd/nfs4state.c
+@@ -4957,6 +4957,7 @@ static int nfsd4_check_conflicting_opens
+ writes--;
+ if (fp->fi_fds[O_RDWR])
+ writes--;
++ WARN_ON_ONCE(writes < 0);
+ if (writes > 0)
+ return -EAGAIN;
+ spin_lock(&fp->fi_lock);
diff --git a/debian/patches/series b/debian/patches/series
index 21a750da2a6a..4468e82f94a5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -91,6 +91,7 @@ debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
bugfix/all/partially-revert-net-socket-implement-64-bit-timestamps.patch
bugfix/all/rdma-srp-fix-support-for-unpopulated-and-unbalanced-numa-nodes.patch
bugfix/all/fuse-fix-live-lock-in-fuse_iget.patch
+bugfix/all/revert-nfsd4-remove-check_conflicting_opens-warning.patch
# Miscellaneous features