aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2015-11-10 22:08:23 +0100
committerSalvatore Bonaccorso <carnil@debian.org>2015-11-10 22:14:32 +0100
commit1d08805288f8fbdbc7d2a870fe8e611e08e99c6f (patch)
tree78e3949eea91bce8601eaa73ce0031610f4b1eb0
parent45bf582b02b2498537081b9ba9796c18d4a67f80 (diff)
downloadkernel_replicant_linux-1d08805288f8fbdbc7d2a870fe8e611e08e99c6f.tar.gz
kernel_replicant_linux-1d08805288f8fbdbc7d2a870fe8e611e08e99c6f.tar.bz2
kernel_replicant_linux-1d08805288f8fbdbc7d2a870fe8e611e08e99c6f.zip
[x86] KVM: rename update_db_bp_intercept to update_bp_intercept
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/x86/kvm-x86-rename-update_db_bp_intercept-to-update_bp_i.patch60
-rw-r--r--debian/patches/series1
3 files changed, 62 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e4562c4b6695..07e185932af3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
linux (4.2.6-2) UNRELEASED; urgency=medium
* [x86] KVM: svm: unconditionally intercept #DB (CVE-2015-8104)
+ * [x86] KVM: rename update_db_bp_intercept to update_bp_intercept
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 10 Nov 2015 22:05:58 +0100
diff --git a/debian/patches/bugfix/x86/kvm-x86-rename-update_db_bp_intercept-to-update_bp_i.patch b/debian/patches/bugfix/x86/kvm-x86-rename-update_db_bp_intercept-to-update_bp_i.patch
new file mode 100644
index 000000000000..84b1486fa2a8
--- /dev/null
+++ b/debian/patches/bugfix/x86/kvm-x86-rename-update_db_bp_intercept-to-update_bp_i.patch
@@ -0,0 +1,60 @@
+From: Paolo Bonzini <pbonzini@redhat.com>
+Date: Tue, 10 Nov 2015 05:24:00 -0700
+Subject: KVM: x86: rename update_db_bp_intercept to update_bp_intercept
+Origin: https://bugzilla.novell.com/attachment.cgi?id=655406
+
+Because #DB is now intercepted unconditionally, this callback
+only operates on #BP for both VMX and SVM.
+
+Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
+---
+ arch/x86/include/asm/kvm_host.h | 2 +-
+ arch/x86/kvm/svm.c | 2 +-
+ arch/x86/kvm/vmx.c | 2 +-
+ arch/x86/kvm/x86.c | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- a/arch/x86/include/asm/kvm_host.h
++++ b/arch/x86/include/asm/kvm_host.h
+@@ -739,7 +739,7 @@ struct kvm_x86_ops {
+ void (*vcpu_load)(struct kvm_vcpu *vcpu, int cpu);
+ void (*vcpu_put)(struct kvm_vcpu *vcpu);
+
+- void (*update_db_bp_intercept)(struct kvm_vcpu *vcpu);
++ void (*update_bp_intercept)(struct kvm_vcpu *vcpu);
+ int (*get_msr)(struct kvm_vcpu *vcpu, struct msr_data *msr);
+ int (*set_msr)(struct kvm_vcpu *vcpu, struct msr_data *msr);
+ u64 (*get_segment_base)(struct kvm_vcpu *vcpu, int seg);
+--- a/arch/x86/kvm/svm.c
++++ b/arch/x86/kvm/svm.c
+@@ -4374,7 +4374,7 @@ static struct kvm_x86_ops svm_x86_ops =
+ .vcpu_load = svm_vcpu_load,
+ .vcpu_put = svm_vcpu_put,
+
+- .update_db_bp_intercept = update_bp_intercept,
++ .update_bp_intercept = update_bp_intercept,
+ .get_msr = svm_get_msr,
+ .set_msr = svm_set_msr,
+ .get_segment_base = svm_get_segment_base,
+--- a/arch/x86/kvm/vmx.c
++++ b/arch/x86/kvm/vmx.c
+@@ -10335,7 +10335,7 @@ static struct kvm_x86_ops vmx_x86_ops =
+ .vcpu_load = vmx_vcpu_load,
+ .vcpu_put = vmx_vcpu_put,
+
+- .update_db_bp_intercept = update_exception_bitmap,
++ .update_bp_intercept = update_exception_bitmap,
+ .get_msr = vmx_get_msr,
+ .set_msr = vmx_set_msr,
+ .get_segment_base = vmx_get_segment_base,
+--- a/arch/x86/kvm/x86.c
++++ b/arch/x86/kvm/x86.c
+@@ -7184,7 +7184,7 @@ int kvm_arch_vcpu_ioctl_set_guest_debug(
+ */
+ kvm_set_rflags(vcpu, rflags);
+
+- kvm_x86_ops->update_db_bp_intercept(vcpu);
++ kvm_x86_ops->update_bp_intercept(vcpu);
+
+ r = 0;
+
diff --git a/debian/patches/series b/debian/patches/series
index 059206c4b1c2..2ea6dec9ec89 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -109,3 +109,4 @@ bugfix/all/media-media-vivid-osd-fix-info-leak-in-ioctl.patch
bugfix/x86/kvm-x86-vmx-avoid-guest-host-dos-by-intercepting-ac.patch
bugfix/x86/kvm-x86-svm-intercept-ac-to-avoid-guest-host-exploit.patch
bugfix/x86/kvm-svm-unconditionally-intercept-DB.patch
+bugfix/x86/kvm-x86-rename-update_db_bp_intercept-to-update_bp_i.patch