aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-01-08 19:32:30 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-01-08 19:32:35 +0000
commitd2547e35612bd42263d6c74e73d072d8bce416db (patch)
treed3a4aaea88ba6f70d3ae57e0f600e1f3938c7ced
parent0c23e537455be4451b48b1bb9117083634060fc3 (diff)
downloadkernel_replicant_linux-d2547e35612bd42263d6c74e73d072d8bce416db.tar.gz
kernel_replicant_linux-d2547e35612bd42263d6c74e73d072d8bce416db.tar.bz2
kernel_replicant_linux-d2547e35612bd42263d6c74e73d072d8bce416db.zip
xen/gntdev: Grant maps should not be subject to NUMA balancing (Closes: #810472)
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/bugfix/all/xen-gntdev-grant-maps-should-not-be-subject-to-numa-.patch38
-rw-r--r--debian/patches/series1
3 files changed, 41 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f6c60588230..7312da61483e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ linux (4.3.3-6) UNRELEASED; urgency=medium
* genorig.py: Make orig tarballs really reproducible:
- Override umask while extracting/exporting files
- Override user and group names in tarball
+ * xen/gntdev: Grant maps should not be subject to NUMA balancing
+ (Closes: #810472)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 08 Jan 2016 12:08:13 +0000
diff --git a/debian/patches/bugfix/all/xen-gntdev-grant-maps-should-not-be-subject-to-numa-.patch b/debian/patches/bugfix/all/xen-gntdev-grant-maps-should-not-be-subject-to-numa-.patch
new file mode 100644
index 000000000000..6da7b5eb8c18
--- /dev/null
+++ b/debian/patches/bugfix/all/xen-gntdev-grant-maps-should-not-be-subject-to-numa-.patch
@@ -0,0 +1,38 @@
+From: Boris Ostrovsky <boris.ostrovsky@oracle.com>
+Date: Tue, 10 Nov 2015 15:10:33 -0500
+Subject: xen/gntdev: Grant maps should not be subject to NUMA balancing
+Origin: https://git.kernel.org/linus/9c17d96500f78d7ecdb71ca6942830158bc75a2b
+Bug-Debian: https://bugs.debian.org/810472
+
+Doing so will cause the grant to be unmapped and then, during
+fault handling, the fault to be mistakenly treated as NUMA hint
+fault.
+
+In addition, even if those maps could partcipate in NUMA
+balancing, it wouldn't provide any benefit since we are unable
+to determine physical page's node (even if/when VNUMA is
+implemented).
+
+Marking grant maps' VMAs as VM_IO will exclude them from being
+part of NUMA balancing.
+
+Signed-off-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
+Cc: stable@vger.kernel.org
+Signed-off-by: David Vrabel <david.vrabel@citrix.com>
+---
+ drivers/xen/gntdev.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/xen/gntdev.c b/drivers/xen/gntdev.c
+index 2ea0b3b..1be5dd0 100644
+--- a/drivers/xen/gntdev.c
++++ b/drivers/xen/gntdev.c
+@@ -804,7 +804,7 @@ static int gntdev_mmap(struct file *flip, struct vm_area_struct *vma)
+
+ vma->vm_ops = &gntdev_vmops;
+
+- vma->vm_flags |= VM_DONTEXPAND | VM_DONTDUMP;
++ vma->vm_flags |= VM_DONTEXPAND | VM_DONTDUMP | VM_IO;
+
+ if (use_ptemod)
+ vma->vm_flags |= VM_DONTCOPY;
diff --git a/debian/patches/series b/debian/patches/series
index b5047714d9f5..4cb278c37c7c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -133,3 +133,4 @@ bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch
bugfix/x86/drm-i915-don-t-compare-has_drrs-strictly-in-pipe-con.patch
bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch
bugfix/all/revert-xhci-don-t-finish-a-td-if-we-get-a-short-transfer.patch
+bugfix/all/xen-gntdev-grant-maps-should-not-be-subject-to-numa-.patch