aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-01-19 22:23:15 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-01-19 22:23:15 +0000
commit2e65ee9ec726be100364774f07dbad4b6208d8b5 (patch)
tree123acc822a17acd3b2a201fd42ba9f83d3ef4068
parent72a63706a060ff9583dd185a58cab2e974ae9912 (diff)
parent33cd223d586dc562f96dbc9b701513ebd1099c08 (diff)
downloadkernel_replicant_linux-2e65ee9ec726be100364774f07dbad4b6208d8b5.tar.gz
kernel_replicant_linux-2e65ee9ec726be100364774f07dbad4b6208d8b5.tar.bz2
kernel_replicant_linux-2e65ee9ec726be100364774f07dbad4b6208d8b5.zip
Merge tag 'debian/4.3.3-7'
-rw-r--r--debian/changelog7
-rw-r--r--debian/rules.real15
2 files changed, 15 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 31c8f43766f1..a623a483c55a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -94,6 +94,13 @@ linux (4.4~rc4-1~exp1) experimental; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Sun, 13 Dec 2015 16:25:45 +0000
+linux (4.3.3-7) unstable; urgency=medium
+
+ * linux-image-dbg: Don't rely on upstream makefile to make .build-id
+ links to vDSO debuginfo (fixes FTBFS on arm64, s390)
+
+ -- Ben Hutchings <ben@decadent.org.uk> Tue, 19 Jan 2016 17:29:21 +0000
+
linux (4.3.3-6) unstable; urgency=medium
[ Ben Hutchings ]
diff --git a/debian/rules.real b/debian/rules.real
index 9a284baa448b..a2db24504bf0 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -431,14 +431,15 @@ ifeq ($(MODULES),True)
endif
ifeq ($(VDSO),True)
+$(MAKE_CLEAN) -C $(DIR) vdso_install INSTALL_MOD_PATH='$(CURDIR)'/$(DEBUG_DIR)
-# Fix .build-id links
- find $(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/vdso/.build-id -name '*.debug' | while read link; do \
- rel_path="$${link#$(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/vdso/.build-id/}" && \
- mkdir -p "$(DEBUG_DIR)/.build-id/$$(dirname "$$rel_path")" && \
- ln -s -r -L "$$link" "$(DEBUG_DIR)/.build-id/$$rel_path" || \
- exit; \
+# Create .build-id links. Some architectures already do so, but in the
+# wrong place, so delete those first.
+ rm -rf $(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/vdso/.build-id
+ find $(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/vdso/ -type f | while read vdso; do \
+ if buildid="$$(readelf -n "$$vdso" | sed -rne 's/^\s+Build ID: (.*)$$/\1/p')" && [ "$$buildid" ]; then \
+ mkdir -p "$(DEBUG_DIR)/.build-id/$${buildid:0:2}"; \
+ ln -s -r "$$vdso" "$(DEBUG_DIR)/.build-id/$${buildid:0:2}/$${buildid:2}.debug"; \
+ fi; \
done
- rm -r $(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/vdso/.build-id
endif
# Add symlinks to vmlinux from the locations expected by kdump-tools,
# systemtap and others