aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-01-01 19:46:24 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-01-01 19:46:24 +0000
commit50c5af235807eacf72db7c62ca117d7eeeda79d1 (patch)
tree879f7bee672d9b992d339364eb39bc8dd7d310b9
parent50263628e4c71c8c18a47317da22494ffd471a51 (diff)
downloadkernel_replicant_linux-50c5af235807eacf72db7c62ca117d7eeeda79d1.tar.gz
kernel_replicant_linux-50c5af235807eacf72db7c62ca117d7eeeda79d1.tar.bz2
kernel_replicant_linux-50c5af235807eacf72db7c62ca117d7eeeda79d1.zip
[armhf] crypto: sun4i-ss - add missing statesize (Closes: #808625)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch40
-rw-r--r--debian/patches/series1
3 files changed, 42 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9cf353f1b33e..d55dff2f2e33 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,7 @@ linux (4.3.3-3) UNRELEASED; urgency=medium
* drm/nouveau/pmu: do not assume a PMU is present (Closes: #809481)
* [x86] drm/i915: Don't compare has_drrs strictly in pipe config
(Closes: #808720)
+ * [armhf] crypto: sun4i-ss - add missing statesize (Closes: #808625)
[ Salvatore Bonaccorso ]
* ovl: fix permission checking for setattr (CVE-2015-8660)
diff --git a/debian/patches/bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch b/debian/patches/bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch
new file mode 100644
index 000000000000..7aace658ee86
--- /dev/null
+++ b/debian/patches/bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch
@@ -0,0 +1,40 @@
+From: LABBE Corentin <clabbe.montjoie@gmail.com>
+Date: Mon, 16 Nov 2015 09:35:54 +0100
+Subject: crypto: sun4i-ss - add missing statesize
+Origin: https://git.kernel.org/cgit/linux/kernel/git/herbert/cryptodev-2.6.git/commit?id=4f9ea86604e3ba64edd2817795798168fbb3c1a6
+Bug-Debian: https://bugs.debian.org/808625
+
+sun4i-ss implementaton of md5/sha1 is via ahash algorithms.
+Commit 8996eafdcbad ("crypto: ahash - ensure statesize is non-zero")
+made impossible to load them without giving statesize. This patch
+specifiy statesize for sha1 and md5.
+
+Fixes: 6298e948215f ("crypto: sunxi-ss - Add Allwinner Security System crypto accelerator")
+Cc: <stable@vger.kernel.org> # v4.3+
+Tested-by: Chen-Yu Tsai <wens@csie.org>
+Signed-off-by: LABBE Corentin <clabbe.montjoie@gmail.com>
+Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
+---
+ drivers/crypto/sunxi-ss/sun4i-ss-core.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/drivers/crypto/sunxi-ss/sun4i-ss-core.c b/drivers/crypto/sunxi-ss/sun4i-ss-core.c
+index eab6fe2..107cd2a 100644
+--- a/drivers/crypto/sunxi-ss/sun4i-ss-core.c
++++ b/drivers/crypto/sunxi-ss/sun4i-ss-core.c
+@@ -39,6 +39,7 @@ static struct sun4i_ss_alg_template ss_algs[] = {
+ .import = sun4i_hash_import_md5,
+ .halg = {
+ .digestsize = MD5_DIGEST_SIZE,
++ .statesize = sizeof(struct md5_state),
+ .base = {
+ .cra_name = "md5",
+ .cra_driver_name = "md5-sun4i-ss",
+@@ -66,6 +67,7 @@ static struct sun4i_ss_alg_template ss_algs[] = {
+ .import = sun4i_hash_import_sha1,
+ .halg = {
+ .digestsize = SHA1_DIGEST_SIZE,
++ .statesize = sizeof(struct sha1_state),
+ .base = {
+ .cra_name = "sha1",
+ .cra_driver_name = "sha1-sun4i-ss",
diff --git a/debian/patches/series b/debian/patches/series
index 5b17d35e174a..8d55435e0001 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -130,3 +130,4 @@ bugfix/all/keys-fix-race-between-read-and-revoke.patch
bugfix/x86/KVM-x86-Reload-pit-counters-for-all-channels-when-re.patch
bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch
bugfix/x86/drm-i915-don-t-compare-has_drrs-strictly-in-pipe-con.patch
+bugfix/arm/crypto-sun4i-ss-add-missing-statesize.patch