aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-01-01 18:41:43 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-01-01 18:41:43 +0000
commit45e2ecad077e7b778c60fff6fc6341469727fa9f (patch)
treec53ca5dc9a2411242cb8321a832d900dbff10c5c
parentd9ebd7436512e9cd0aaab50fc40b33d08322bd3b (diff)
downloadkernel_replicant_linux-45e2ecad077e7b778c60fff6fc6341469727fa9f.tar.gz
kernel_replicant_linux-45e2ecad077e7b778c60fff6fc6341469727fa9f.tar.bz2
kernel_replicant_linux-45e2ecad077e7b778c60fff6fc6341469727fa9f.zip
drm/nouveau/pmu: do not assume a PMU is present (Closes: #809481)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch29
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f1347f70e247..ddcfbcf8982d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ linux (4.3.3-3) UNRELEASED; urgency=medium
* KEYS: Fix race between read and revoke (CVE-2015-7550)
* [armhf] udeb: Add modular clock, GPIO, PHY and regulator drivers to
core-modules (Closes: #809521)
+ * drm/nouveau/pmu: do not assume a PMU is present (Closes: #809481)
[ Salvatore Bonaccorso ]
* ovl: fix permission checking for setattr (CVE-2015-8660)
diff --git a/debian/patches/bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch b/debian/patches/bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch
new file mode 100644
index 000000000000..ae2f294d31d1
--- /dev/null
+++ b/debian/patches/bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch
@@ -0,0 +1,29 @@
+From: Alexandre Courbot <acourbot@nvidia.com>
+Date: Thu, 3 Sep 2015 17:39:52 +0900
+Subject: drm/nouveau/pmu: do not assume a PMU is present
+Origin: https://git.kernel.org/linus/579b7c58215329803ce184704463de09f0f310ac
+Bug-Debian: https://bugs.debian.org/809481
+
+Some devices may not have a PMU. Avoid a NULL pointer dereference in
+such cases by checking whether the pointer given to nvkm_pmu_pgob() is
+valid.
+
+Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
+Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
+---
+ drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c b/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
+index 27a79c0..d95eb86 100644
+--- a/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
++++ b/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
+@@ -28,7 +28,7 @@
+ void
+ nvkm_pmu_pgob(struct nvkm_pmu *pmu, bool enable)
+ {
+- if (pmu->func->pgob)
++ if (pmu && pmu->func->pgob)
+ pmu->func->pgob(pmu, enable);
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index 94167d7a9a87..d762ba14d449 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -128,3 +128,4 @@ bugfix/all/xen-pciback-don-t-allow-msi-x-ops-if-pci_command_mem.patch
bugfix/all/ptrace-being-capable-wrt-a-process-requires-mapped-uids-gids.patch
bugfix/all/keys-fix-race-between-read-and-revoke.patch
bugfix/x86/KVM-x86-Reload-pit-counters-for-all-channels-when-re.patch
+bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch