aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2015-10-27 11:01:28 +0900
committerBen Hutchings <ben@decadent.org.uk>2015-10-27 11:01:28 +0900
commit61407a46ed7f4dee56390a7c0cc997e465336c95 (patch)
tree2713693bd09b90a7ad263b50361f3853023181a1
parentc8050509621461b13324fbf7090c75002cbcfdcc (diff)
downloadkernel_replicant_linux-61407a46ed7f4dee56390a7c0cc997e465336c95.tar.gz
kernel_replicant_linux-61407a46ed7f4dee56390a7c0cc997e465336c95.tar.bz2
kernel_replicant_linux-61407a46ed7f4dee56390a7c0cc997e465336c95.zip
Update to 4.2.5
-rw-r--r--debian/changelog48
-rw-r--r--debian/patches/bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch36
-rw-r--r--debian/patches/series1
3 files changed, 47 insertions, 38 deletions
diff --git a/debian/changelog b/debian/changelog
index 91281a1f47a4..9ab66ff519aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-linux (4.2.4-1) UNRELEASED; urgency=medium
+linux (4.2.5-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.2.4
@@ -257,6 +257,52 @@ linux (4.2.4-1) UNRELEASED; urgency=medium
- sched/preempt, xen: Use need_resched() instead of should_resched()
- sched/preempt, powerpc, kvm: Use need_resched() instead of
should_resched()
+ https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.2.5
+ - [powerpc*] net/ibm/emac: bump version numbers for correct work with
+ ethtool
+ - l2tp: protect tunnel->del_work by ref_count
+ - af_unix: Convert the unix_sk macro to an inline function for type safety
+ - af_unix: return data from multiple SKBs on recv() with MSG_PEEK flag
+ - net/unix: fix logic about sk_peek_offset
+ - skbuff: Fix skb checksum flag on skb pull
+ - skbuff: Fix skb checksum partial check.
+ - inet: fix races in reqsk_queue_hash_req()
+ - net: add pfmemalloc check in sk_add_backlog()
+ - ppp: don't override sk->sk_state in pppoe_flush_dev()
+ - inet: fix race in reqsk_queue_unlink()
+ - bpf: fix panic in SO_GET_FILTER with native ebpf programs
+ - ovs: do not allocate memory from offline numa node
+ - act_mirred: clear sender cpu before sending to tx
+ - bpf: clear sender_cpu before xmit
+ - ipv6: Don't call with rt6_uncached_list_flush_dev
+ - ethtool: Use kcalloc instead of kmalloc for ethtool_get_strings
+ - tipc: move fragment importance field to new header position
+ - netlink: Trim skb to alloc size to avoid MSG_TRUNC
+ - drm: Fix locking for sysfs dpms file
+ - [sparc*] crypto: initialize blkcipher.ivsize
+ - crypto: ahash - ensure statesize is non-zero
+ - memcg: convert threshold to bytes
+ - btrfs: check unsupported filters in balance arguments
+ - btrfs: fix use after free iterating extrefs
+ - [arm64] errata: use KBUILD_CFLAGS_MODULE for erratum #843419
+ - nfsd/blocklayout: accept any minlength
+ - [armhf] i2c: s3c2410: enable RuntimePM before registering to the core
+ - i2c: designware: Do not use parameters from ACPI on Dell Inspiron 7348
+ - i2c: designware-platdrv: enable RuntimePM before registering to the core
+ - workqueue: make sure delayed work run in local cpu
+ - [x86] KVM: fix SMI to halted VCPU
+ - [x86] KVM: fix RSM into 64-bit protected mode
+ - drm/qxl: fix framebuffer dirty rectangle tracking.
+ - drm/nouveau/fbcon: take runpm reference when userspace has an open fd
+ - drm/dp/mst: make mst i2c transfer code more robust.
+ - drm/radeon: attach tile property to mst connector
+ - drm/radeon: add pm sysfs files late
+ - dm thin: fix missing pool reference count decrement in pool_ctr error
+ path
+ - rbd: fix double free on rbd_dev->header_name
+ - timekeeping: Increment clock_was_set_seq in timekeeping_init()
+ - [arm64] Fix THP protection change logic
+ - svcrdma: handle rdma read with a non-zero initial page offset
[ Salvatore Bonaccorso ]
* KEYS: Fix race between key destruction and finding a keyring by name
diff --git a/debian/patches/bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch b/debian/patches/bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch
deleted file mode 100644
index 928504b17c80..000000000000
--- a/debian/patches/bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From: Ben Hutchings <ben@decadent.org.uk>
-Date: Mon, 5 Oct 2015 16:40:01 +0100
-Subject: crypto x86/camellia_aesni_avx: Fix CPU feature checks
-Bug-Debian: https://bugs.debian.org/800934
-Forwarded: http://mid.gmane.org/1444131093.2956.122.camel@decadent.org.uk
-
-We need to explicitly check the AVX and AES CPU features, as we can't
-infer them from the related XSAVE feature flags. For example, the
-Core i3 2310M passes the XSAVE feature test but does not implement
-AES-NI.
-
-Reported-and-tested-by: Stéphane Glondu <glondu@debian.org>
-References: https://bugs.debian.org/800934
-Fixes: ce4f5f9b65ae ("x86/fpu, crypto x86/camellia_aesni_avx: Simplify...")
-Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
-Cc: stable <stable@vger.kernel.org> # 4.2
----
- arch/x86/crypto/camellia_aesni_avx_glue.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/arch/x86/crypto/camellia_aesni_avx_glue.c b/arch/x86/crypto/camellia_aesni_avx_glue.c
-index 80a0e43..bacaa13 100644
---- a/arch/x86/crypto/camellia_aesni_avx_glue.c
-+++ b/arch/x86/crypto/camellia_aesni_avx_glue.c
-@@ -554,6 +554,11 @@ static int __init camellia_aesni_init(void)
- {
- const char *feature_name;
-
-+ if (!cpu_has_avx || !cpu_has_aes || !cpu_has_osxsave) {
-+ pr_info("AVX or AES-NI instructions are not detected.\n");
-+ return -ENODEV;
-+ }
-+
- if (!cpu_has_xfeatures(XSTATE_SSE | XSTATE_YMM, &feature_name)) {
- pr_info("CPU feature '%s' is not supported.\n", feature_name);
- return -ENODEV;
diff --git a/debian/patches/series b/debian/patches/series
index 6181901b1e14..5792e691fed5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -94,7 +94,6 @@ bugfix/mips/mips-pgtable-bits.h-correct-_page_global_shift-build.patch
bugfix/all/ovl-conditionally-use-o_largefile-in-ovl_copy_up.patch
features/all/ath10k-add-qca6164-support.patch
debian/block-fix-abi-change-in-4.2.2.patch
-bugfix/x86/crypto-x86-camellia_aesni_avx-fix-cpu-feature-checks.patch
bugfix/all/nbd-fix-timeout-detection.patch
bugfix/all/nbd-remove-variable-pid.patch
bugfix/all/nbd-add-locking-for-tasks.patch