aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2018-07-12 17:54:58 +0100
committerBen Hutchings <ben@decadent.org.uk>2018-07-12 18:15:03 +0100
commite740d4cf7948fe68edc472cfd54f86a457a6879c (patch)
tree61ce24f72e056520a4381751327e4a98f8a444cc
parent1ce0efc40538a504f420c41a064aa76337a87849 (diff)
downloadkernel_replicant_linux-e740d4cf7948fe68edc472cfd54f86a457a6879c.tar.gz
kernel_replicant_linux-e740d4cf7948fe68edc472cfd54f86a457a6879c.tar.bz2
kernel_replicant_linux-e740d4cf7948fe68edc472cfd54f86a457a6879c.zip
linux-kbuild: Fix the assumed host architecture for cross-built objtool
The previous fix ensured that objtool was built for the right host architecture, but it was still including some UAPI header files (in particular <asm/bitsperlong.h>) for the build architecture.
-rw-r--r--debian/changelog2
-rw-r--r--debian/rules.d/tools/objtool/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6dfd5a5c111f..7102aaea32b1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ linux (4.17.6-2) UNRELEASED; urgency=medium
build-dependency
* debian/rules.real: Pass KERNEL_ARCH variable down to debian/rules.d
* debian/rules.d/tools/perf/Makefile: Use KERNEL_ARCH variable
+ * linux-kbuild: Fix the assumed host architecture for cross-built objtool
+ (fixes FTBFS on at least ppc64)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 12 Jul 2018 15:16:15 +0100
diff --git a/debian/rules.d/tools/objtool/Makefile b/debian/rules.d/tools/objtool/Makefile
index cc2ea9e2201d..6b42618d3000 100644
--- a/debian/rules.d/tools/objtool/Makefile
+++ b/debian/rules.d/tools/objtool/Makefile
@@ -5,7 +5,7 @@ all:
# for multiple targets and add a wrapper, same as for modpost.
# objtool explicitly sets CC and LD to be native tools; we need to override
# this on the command line to make cross-builds work.
- $(MAKE) -C $(top_srcdir)/tools/objtool O=$(CURDIR) ARCH=x86 CC=$(CC) LD=$(CROSS_COMPILE)ld
+ $(MAKE) -C $(top_srcdir)/tools/objtool O=$(CURDIR) HOSTARCH=$(KERNEL_ARCH) ARCH=x86 CC=$(CC) LD=$(CROSS_COMPILE)ld
install:
install -D -m755 objtool $(DESTDIR)/$(installdir)/objtool