aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2017-08-11 09:12:16 +0200
committerSalvatore Bonaccorso <carnil@debian.org>2017-08-11 09:12:58 +0200
commit0442142ae4f2ec95416aac90007f1faa9a14d8c4 (patch)
tree0cdaa4123d0388f23847eb1dba296b67d1bf4a18
parent3b6247dba42d12c7dbcaad64d7ab0e7342e9437b (diff)
downloadkernel_replicant_linux-0442142ae4f2ec95416aac90007f1faa9a14d8c4.tar.gz
kernel_replicant_linux-0442142ae4f2ec95416aac90007f1faa9a14d8c4.tar.bz2
kernel_replicant_linux-0442142ae4f2ec95416aac90007f1faa9a14d8c4.zip
udp: consistently apply ufo or fragmentation (CVE-2017-1000112)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/udp-consistently-apply-ufo-or-fragmentation.patch94
-rw-r--r--debian/patches/series1
3 files changed, 96 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index dee0e3f4b28a..b56e84638aa8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -258,6 +258,7 @@ linux (4.12.5-1~exp1) UNRELEASED; urgency=medium
* ipv6: avoid overflow of offset in ip6_find_1stfragopt (CVE-2017-7542)
* media: saa7164: fix double fetch PCIe access condition (CVE-2017-8831)
* packet: fix tp_reserve race in packet_set_ring (CVE-2017-1000111)
+ * udp: consistently apply ufo or fragmentation (CVE-2017-1000112)
[ Uwe Kleine-König ]
* [arm64] enable MMC_SDHCI_XENON and MVNETA for Espressobin and enable
diff --git a/debian/patches/bugfix/all/udp-consistently-apply-ufo-or-fragmentation.patch b/debian/patches/bugfix/all/udp-consistently-apply-ufo-or-fragmentation.patch
new file mode 100644
index 000000000000..5233c274146b
--- /dev/null
+++ b/debian/patches/bugfix/all/udp-consistently-apply-ufo-or-fragmentation.patch
@@ -0,0 +1,94 @@
+From: Willem de Bruijn <willemb@google.com>
+Date: Thu, 10 Aug 2017 12:29:19 -0400
+Subject: udp: consistently apply ufo or fragmentation
+Origin: https://git.kernel.org/linus/85f1bd9a7b5a79d5baa8bf44af19658f7bf77bfa
+Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-1000112
+
+When iteratively building a UDP datagram with MSG_MORE and that
+datagram exceeds MTU, consistently choose UFO or fragmentation.
+
+Once skb_is_gso, always apply ufo. Conversely, once a datagram is
+split across multiple skbs, do not consider ufo.
+
+Sendpage already maintains the first invariant, only add the second.
+IPv6 does not have a sendpage implementation to modify.
+
+A gso skb must have a partial checksum, do not follow sk_no_check_tx
+in udp_send_skb.
+
+Found by syzkaller.
+
+Fixes: e89e9cf539a2 ("[IPv4/IPv6]: UFO Scatter-gather approach")
+Reported-by: Andrey Konovalov <andreyknvl@google.com>
+Signed-off-by: Willem de Bruijn <willemb@google.com>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ net/ipv4/ip_output.c | 8 +++++---
+ net/ipv4/udp.c | 2 +-
+ net/ipv6/ip6_output.c | 7 ++++---
+ 3 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/net/ipv4/ip_output.c b/net/ipv4/ip_output.c
+index 50c74cd890bc..e153c40c2436 100644
+--- a/net/ipv4/ip_output.c
++++ b/net/ipv4/ip_output.c
+@@ -965,11 +965,12 @@ static int __ip_append_data(struct sock *sk,
+ csummode = CHECKSUM_PARTIAL;
+
+ cork->length += length;
+- if ((((length + (skb ? skb->len : fragheaderlen)) > mtu) ||
+- (skb && skb_is_gso(skb))) &&
++ if ((skb && skb_is_gso(skb)) ||
++ (((length + (skb ? skb->len : fragheaderlen)) > mtu) &&
++ (skb_queue_len(queue) <= 1) &&
+ (sk->sk_protocol == IPPROTO_UDP) &&
+ (rt->dst.dev->features & NETIF_F_UFO) && !dst_xfrm(&rt->dst) &&
+- (sk->sk_type == SOCK_DGRAM) && !sk->sk_no_check_tx) {
++ (sk->sk_type == SOCK_DGRAM) && !sk->sk_no_check_tx)) {
+ err = ip_ufo_append_data(sk, queue, getfrag, from, length,
+ hh_len, fragheaderlen, transhdrlen,
+ maxfraglen, flags);
+@@ -1288,6 +1289,7 @@ ssize_t ip_append_page(struct sock *sk, struct flowi4 *fl4, struct page *page,
+ return -EINVAL;
+
+ if ((size + skb->len > mtu) &&
++ (skb_queue_len(&sk->sk_write_queue) == 1) &&
+ (sk->sk_protocol == IPPROTO_UDP) &&
+ (rt->dst.dev->features & NETIF_F_UFO)) {
+ if (skb->ip_summed != CHECKSUM_PARTIAL)
+diff --git a/net/ipv4/udp.c b/net/ipv4/udp.c
+index e6276fa3750b..a7c804f73990 100644
+--- a/net/ipv4/udp.c
++++ b/net/ipv4/udp.c
+@@ -802,7 +802,7 @@ static int udp_send_skb(struct sk_buff *skb, struct flowi4 *fl4)
+ if (is_udplite) /* UDP-Lite */
+ csum = udplite_csum(skb);
+
+- else if (sk->sk_no_check_tx) { /* UDP csum disabled */
++ else if (sk->sk_no_check_tx && !skb_is_gso(skb)) { /* UDP csum off */
+
+ skb->ip_summed = CHECKSUM_NONE;
+ goto send;
+diff --git a/net/ipv6/ip6_output.c b/net/ipv6/ip6_output.c
+index 162efba0d0cd..2dfe50d8d609 100644
+--- a/net/ipv6/ip6_output.c
++++ b/net/ipv6/ip6_output.c
+@@ -1381,11 +1381,12 @@ static int __ip6_append_data(struct sock *sk,
+ */
+
+ cork->length += length;
+- if ((((length + (skb ? skb->len : headersize)) > mtu) ||
+- (skb && skb_is_gso(skb))) &&
++ if ((skb && skb_is_gso(skb)) ||
++ (((length + (skb ? skb->len : headersize)) > mtu) &&
++ (skb_queue_len(queue) <= 1) &&
+ (sk->sk_protocol == IPPROTO_UDP) &&
+ (rt->dst.dev->features & NETIF_F_UFO) && !dst_xfrm(&rt->dst) &&
+- (sk->sk_type == SOCK_DGRAM) && !udp_get_no_check6_tx(sk)) {
++ (sk->sk_type == SOCK_DGRAM) && !udp_get_no_check6_tx(sk))) {
+ err = ip6_ufo_append_data(sk, queue, getfrag, from, length,
+ hh_len, fragheaderlen, exthdrlen,
+ transhdrlen, mtu, flags, fl6);
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
index 95ad2aecae33..c211945f130a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -122,6 +122,7 @@ debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/ipv6-avoid-overflow-of-offset-in-ip6_find_1stfragopt.patch
bugfix/all/media-saa7164-fix-double-fetch-PCIe-access-condition.patch
bugfix/all/packet-fix-tp_reserve-race-in-packet_set_ring.patch
+bugfix/all/udp-consistently-apply-ufo-or-fragmentation.patch
# Fix exported symbol versions
bugfix/alpha/alpha-restore-symbol-versions-for-symbols-exported-f.patch