aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2012-12-24 00:10:56 +0000
committerBen Hutchings <benh@debian.org>2012-12-24 00:10:56 +0000
commitdf5911f38560ea94124fcc1492480e44cb04d87d (patch)
tree4f6692f570e42baa2367cbd6df4aa1afff7bb129
parentd2bb26f3676218e700efbeee77affe236360309b (diff)
downloadkernel_replicant_linux-df5911f38560ea94124fcc1492480e44cb04d87d.tar.gz
kernel_replicant_linux-df5911f38560ea94124fcc1492480e44cb04d87d.tar.bz2
kernel_replicant_linux-df5911f38560ea94124fcc1492480e44cb04d87d.zip
[x86] drm: Enable DRM_MGAG200 as module
Disable autoloading as it is incompatible with older versions of xserver-xorg-video-mga svn path=/dists/trunk/linux/; revision=19646
-rw-r--r--debian/changelog6
-rw-r--r--debian/config/config5
-rw-r--r--debian/config/kernelarch-x86/config5
-rw-r--r--debian/patches/debian/mgag200-disable-autoload.patch20
-rw-r--r--debian/patches/series1
5 files changed, 34 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 64d0b160ad4b..d9c650042f16 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -48,9 +48,9 @@ linux (3.7.1-1~experimental.1) UNRELEASED; urgency=low
* drm: Enable DRM_UDL as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-displaylink
- * [x86] drm: Enable DRM_AST as module
- - Disable autoloading as it is incompatible with older versions of
- xserver-xorg-video-ast
+ * [x86] drm: Enable DRM_AST, DRM_MGAG200 as modules
+ - Disable autoloading as they are incompatible with older versions of
+ xserver-xorg-video-ast and xserver-xorg-video-mga
-- maximilian attems <maks@debian.org> Thu, 06 Dec 2012 18:14:33 +0100
diff --git a/debian/config/config b/debian/config/config
index aec9077cab31..c3fe57708f25 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -405,6 +405,11 @@ CONFIG_DRM_SAVAGE=m
CONFIG_DRM_CIRRUS_QEMU=m
##
+## file: drivers/gpu/drm/mgag200/Kconfig
+##
+# CONFIG_DRM_MGAG200 is not set
+
+##
## file: drivers/gpu/drm/nouveau/Kconfig
##
CONFIG_DRM_NOUVEAU=m
diff --git a/debian/config/kernelarch-x86/config b/debian/config/kernelarch-x86/config
index 61081f6ea46b..d8ecf67aa031 100644
--- a/debian/config/kernelarch-x86/config
+++ b/debian/config/kernelarch-x86/config
@@ -449,6 +449,11 @@ CONFIG_DRM_GMA600=y
CONFIG_DRM_GMA3600=y
##
+## file: drivers/gpu/drm/mgag200/Kconfig
+##
+CONFIG_DRM_MGAG200=m
+
+##
## file: drivers/gpu/drm/nouveau/Kconfig
##
CONFIG_DRM_NOUVEAU=m
diff --git a/debian/patches/debian/mgag200-disable-autoload.patch b/debian/patches/debian/mgag200-disable-autoload.patch
new file mode 100644
index 000000000000..cac1aa5eb3bd
--- /dev/null
+++ b/debian/patches/debian/mgag200-disable-autoload.patch
@@ -0,0 +1,20 @@
+From: Ben Hutchings <ben@decadent.org.uk>
+Subject: mgag200: Disable autoload
+Date: Mon, 24 Dec 2012 00:10:05 +0000
+
+This kernel driver is incompatible with older versions of
+xserver-xorg-video-mga, so do not autoload it yet. It will have to be
+loaded either by local configuration or as part of a package of a
+compatible X driver.
+
+--- a/drivers/gpu/drm/mgag200/mgag200_drv.c
++++ b/drivers/gpu/drm/mgag200/mgag200_drv.c
+@@ -38,7 +38,7 @@ static DEFINE_PCI_DEVICE_TABLE(pciidlist
+ {0,}
+ };
+
+-MODULE_DEVICE_TABLE(pci, pciidlist);
++/*MODULE_DEVICE_TABLE(pci, pciidlist);*/
+
+ static void mgag200_kick_out_firmware_fb(struct pci_dev *pdev)
+ {
diff --git a/debian/patches/series b/debian/patches/series
index ef2a55f4fcda..b5f0a16b3ab1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -67,3 +67,4 @@ bugfix/all/sfc-Select-PTP_1588_CLOCK.patch
bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch
debian/ast-disable-autoload.patch
+debian/mgag200-disable-autoload.patch