aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2012-10-04 13:06:29 +0000
committerBastian Blank <waldi@debian.org>2012-10-04 13:06:29 +0000
commitec81c659a52b9d7475503f942ad02b19114836ae (patch)
tree1b791ab2e87c18ec9de5c2a728cedc181a428fde
parent31c831977e467f34dd934d48cafaf156a52f02a2 (diff)
downloadkernel_replicant_linux-ec81c659a52b9d7475503f942ad02b19114836ae.tar.gz
kernel_replicant_linux-ec81c659a52b9d7475503f942ad02b19114836ae.tar.bz2
kernel_replicant_linux-ec81c659a52b9d7475503f942ad02b19114836ae.zip
debian/rules, debian/rules.real: Remove unneeded chmod calls.
svn path=/dists/trunk/linux/; revision=19405
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/rules.real2
2 files changed, 0 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index cb885511de83..bdd1d24f1069 100755
--- a/debian/rules
+++ b/debian/rules
@@ -96,7 +96,6 @@ else
endif
debian/control-real: debian/bin/gencontrol.py $(CONTROL_FILES)
- chmod +x $<
$<
md5sum $^ > debian/control.md5sum
@echo
diff --git a/debian/rules.real b/debian/rules.real
index 9d48b922b377..bc9a61103c4c 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -359,7 +359,6 @@ install-image_$(ARCH)_$(FEATURESET)_$(FLAVOUR)_plain:
install-image_$(ARCH)_$(FEATURESET)_$(FLAVOUR)_plain_image \
DIR='$(DIR)' PACKAGE_DIR='$(PACKAGE_DIR)' INSTALL_DIR='$(INSTALL_DIR)' REAL_VERSION='$(REAL_VERSION)'
ifeq ($(MODULES),True)
- chmod a+x $(CURDIR)/debian/bin/no-depmod
+$(MAKE_CLEAN) -C $(DIR) modules_install DEPMOD='$(CURDIR)/debian/bin/no-depmod' INSTALL_MOD_PATH='$(CURDIR)'/$(PACKAGE_DIR) INSTALL_MOD_STRIP=1
ifeq ($(DEBUG),True)
find $(PACKAGE_DIR) -name '*.ko' | sed 's|$(PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/kernel/||' | while read module ; do \
@@ -486,7 +485,6 @@ install-image-dbg_$(ARCH)_$(FEATURESET)_$(FLAVOUR): $(STAMPS_DIR)/build_$(ARCH)_
> $(PACKAGE_DIR)/usr/share/lintian/overrides/$(PACKAGE_NAME)
install -m644 $(DIR)/vmlinux $(DEBUG_DIR)/boot/vmlinux-$(REAL_VERSION)
ifeq ($(MODULES),True)
- chmod a+x $(CURDIR)/debian/bin/no-depmod
+$(MAKE_CLEAN) -C $(DIR) modules_install DEPMOD='$(CURDIR)/debian/bin/no-depmod' INSTALL_MOD_PATH='$(CURDIR)'/$(DEBUG_DIR)
find $(DEBUG_DIR)/lib/modules/$(REAL_VERSION)/ -mindepth 1 -maxdepth 1 \! -name kernel -exec rm {} \+
rm $(DEBUG_DIR)/lib/firmware -rf