aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2012-04-09 04:05:34 +0000
committerBen Hutchings <benh@debian.org>2012-04-09 04:05:34 +0000
commit52fc1edcc2183b8e3d65dd1557fece6c75f5aa53 (patch)
treeb1360ea14a10cdff5809f2cfb97e658a2f065281
parent3121d0925667d07235ff1f7ff197c31a1d0190df (diff)
downloadkernel_replicant_linux-52fc1edcc2183b8e3d65dd1557fece6c75f5aa53.tar.gz
kernel_replicant_linux-52fc1edcc2183b8e3d65dd1557fece6c75f5aa53.tar.bz2
kernel_replicant_linux-52fc1edcc2183b8e3d65dd1557fece6c75f5aa53.zip
nfs: Fix length of buffer copied in __nfs4_get_acl_uncached
svn path=/dists/sid/linux-2.6/; revision=18922
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/nfs-Fix-length-of-buffer-copied-in-__nfs4_get_acl_uncach.patch33
-rw-r--r--debian/patches/series/base2
3 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5a8c97c2bf98..31307355d0fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ linux-2.6 (3.2.14-2) UNRELEASED; urgency=low
* TOMOYO: Fix mount flags checking order.
* drm/radeon/kms: fix fans after resume (Closes: #596741)
* [x86] hv: Update all Hyper-V drivers to 3.4-rc1 (Closes: #661318)
+ * nfs: Fix length of buffer copied in __nfs4_get_acl_uncached
[ Jonathan Nieder ]
* [x86] ioat: fix size of 'completion' for Xen (Closes: #660554)
diff --git a/debian/patches/bugfix/all/nfs-Fix-length-of-buffer-copied-in-__nfs4_get_acl_uncach.patch b/debian/patches/bugfix/all/nfs-Fix-length-of-buffer-copied-in-__nfs4_get_acl_uncach.patch
new file mode 100644
index 000000000000..49f591919d28
--- /dev/null
+++ b/debian/patches/bugfix/all/nfs-Fix-length-of-buffer-copied-in-__nfs4_get_acl_uncach.patch
@@ -0,0 +1,33 @@
+From: Sachin Prabhu <sprabhu@redhat.com>
+Date: Thu, 22 Mar 2012 16:46:28 +0000
+Subject: [PATCH] Fix length of buffer copied in __nfs4_get_acl_uncached
+
+commit 20e0fa98b751facf9a1101edaefbc19c82616a68 upstream.
+
+_copy_from_pages() used to copy data from the temporary buffer to the
+user passed buffer is passed the wrong size parameter when copying
+data. res.acl_len contains both the bitmap and acl lenghts while
+acl_len contains the acl length after adjusting for the bitmap size.
+
+Signed-off-by: Sachin Prabhu <sprabhu@redhat.com>
+Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>
+---
+ fs/nfs/nfs4proc.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fs/nfs/nfs4proc.c b/fs/nfs/nfs4proc.c
+index e809d23..45df7d4 100644
+--- a/fs/nfs/nfs4proc.c
++++ b/fs/nfs/nfs4proc.c
+@@ -3712,7 +3712,7 @@ static ssize_t __nfs4_get_acl_uncached(struct inode *inode, void *buf, size_t bu
+ if (acl_len > buflen)
+ goto out_free;
+ _copy_from_pages(buf, pages, res.acl_data_offset,
+- res.acl_len);
++ acl_len);
+ }
+ ret = acl_len;
+ out_free:
+--
+1.7.9.5
+
diff --git a/debian/patches/series/base b/debian/patches/series/base
index ef75de46d281..bfdd3fd079d1 100644
--- a/debian/patches/series/base
+++ b/debian/patches/series/base
@@ -177,3 +177,5 @@
# Temporary, until the next ABI bump
+ debian/revert-rtc-Provide-flag-for-rtc-devices-that-don-t-s.patch
+ debian/nls-Avoid-ABI-change-from-improvement-to-utf8s_to_ut.patch
+
++ bugfix/all/nfs-Fix-length-of-buffer-copied-in-__nfs4_get_acl_uncach.patch