aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2012-06-13 02:38:58 +0000
committerBen Hutchings <benh@debian.org>2012-06-13 02:38:58 +0000
commit157024aa14f72588de129a185deccbfa176d411d (patch)
treecc59e675fe2e2dd3956e7ca5974f4588334ee525
parenta6746fd61b216d1c11dba2ac8a4ffe0c43e785fa (diff)
downloadkernel_replicant_linux-157024aa14f72588de129a185deccbfa176d411d.tar.gz
kernel_replicant_linux-157024aa14f72588de129a185deccbfa176d411d.tar.bz2
kernel_replicant_linux-157024aa14f72588de129a185deccbfa176d411d.zip
ethtool: allow ETHTOOL_GSSET_INFO for users
svn path=/dists/sid/linux/; revision=19144
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/ethtool-allow-ETHTOOL_GSSET_INFO-for-users.patch31
-rw-r--r--debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bbde6fa15308..f8dcfc8c81af 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ linux (3.2.20-2) UNRELEASED; urgency=low
* [ia64,powerpc] udeb: Add crc-itu-t to crc-modules; make
firewire-core-modules depend on it (fixes FTBFS)
* [arm,m68k,sh4] udeb: Build ipv6-modules
+ * ethtool: allow ETHTOOL_GSSET_INFO for users
[ Aurelien Jarno ]
* [mips,mipsel] udeb: Remove rivafb and nvidiafb.
diff --git a/debian/patches/bugfix/all/ethtool-allow-ETHTOOL_GSSET_INFO-for-users.patch b/debian/patches/bugfix/all/ethtool-allow-ETHTOOL_GSSET_INFO-for-users.patch
new file mode 100644
index 000000000000..f40e768e167a
--- /dev/null
+++ b/debian/patches/bugfix/all/ethtool-allow-ETHTOOL_GSSET_INFO-for-users.patch
@@ -0,0 +1,31 @@
+From: =?UTF-8?q?Micha=C5=82=20Miros=C5=82aw?= <mirq-linux@rere.qmqm.pl>
+Date: Sun, 22 Jan 2012 00:20:40 +0000
+Subject: ethtool: allow ETHTOOL_GSSET_INFO for users
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+commit f80400a26a2e8bff541de12834a1134358bb6642 upstream.
+
+Allow ETHTOOL_GSSET_INFO ethtool ioctl() for unprivileged users.
+ETHTOOL_GSTRINGS is already allowed, but is unusable without this one.
+
+Signed-off-by: Michał Mirosław <mirq-linux@rere.qmqm.pl>
+Acked-by: Ben Hutchings <bhutchings@solarflare.com>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ net/core/ethtool.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/net/core/ethtool.c b/net/core/ethtool.c
+index 921aa2b..369b418 100644
+--- a/net/core/ethtool.c
++++ b/net/core/ethtool.c
+@@ -1311,6 +1311,7 @@ int dev_ethtool(struct net *net, struct ifreq *ifr)
+ case ETHTOOL_GRXCSUM:
+ case ETHTOOL_GTXCSUM:
+ case ETHTOOL_GSG:
++ case ETHTOOL_GSSET_INFO:
+ case ETHTOOL_GSTRINGS:
+ case ETHTOOL_GTSO:
+ case ETHTOOL_GPERMADDR:
diff --git a/debian/patches/series b/debian/patches/series
index 85f31202de8c..28bfd24b0864 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -326,3 +326,4 @@ bugfix/all/macvtap-zerocopy-set-SKBTX_DEV_ZEROCOPY-only-when-sk.patch
bugfix/all/macvtap-zerocopy-validate-vectors-before-building-sk.patch
bugfix/all/KVM-Fix-buffer-overflow-in-kvm_set_irq.patch
+bugfix/all/ethtool-allow-ETHTOOL_GSSET_INFO-for-users.patch