aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2012-06-27 02:00:16 +0000
committerBen Hutchings <benh@debian.org>2012-06-27 02:00:16 +0000
commit0be856837de51a83cac46ed165c4b28aee59fcd4 (patch)
treeb8c7c1621163d6ffd8a2de77cf8864a6adf09a2c
parenta98051c79eaf95a060ae65df6b425a0716067fd0 (diff)
downloadkernel_replicant_linux-0be856837de51a83cac46ed165c4b28aee59fcd4.tar.gz
kernel_replicant_linux-0be856837de51a83cac46ed165c4b28aee59fcd4.tar.bz2
kernel_replicant_linux-0be856837de51a83cac46ed165c4b28aee59fcd4.zip
driver core: remove __must_check from device_create_file (fixes FTBFS on sparc)
svn path=/dists/sid/linux/; revision=19218
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch36
-rw-r--r--debian/patches/series1
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 46d242462251..ad554ec2a545 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+linux (3.2.21-3) UNRELEASED; urgency=low
+
+ * driver core: remove __must_check from device_create_file
+ (fixes FTBFS on sparc)
+
+ -- Ben Hutchings <ben@decadent.org.uk> Wed, 27 Jun 2012 02:56:49 +0100
+
linux (3.2.21-2) unstable; urgency=low
* [i386] cpufreq/gx: Fix the compile error
diff --git a/debian/patches/features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch b/debian/patches/features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch
new file mode 100644
index 000000000000..bc69feb0de0a
--- /dev/null
+++ b/debian/patches/features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch
@@ -0,0 +1,36 @@
+From: Greg Kroah-Hartman <gregkh@suse.de>
+Date: Wed, 4 Jan 2012 15:05:10 -0800
+Subject: driver core: remove __must_check from device_create_file
+
+commit b9d4e714a86a4e88c2f530c76597f7025e5851d6 upstream.
+
+With the conversion of the sysdev to a real struct device, more drivers
+are calling device_create_file, and some of them don't check the return
+value, which isn't wise.
+
+But as they happen to be in parts of the kernel where a warning is
+considered an error (i.e. powerpc), this breaks the build. So for now,
+remove the marking on the function, which fixes the build problems.
+
+Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
+Cc: Kay Sievers <kay.sievers@vrfy.org>
+Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
+---
+ include/linux/device.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/linux/device.h b/include/linux/device.h
+index 7f9fc15..acf505e 100644
+--- a/include/linux/device.h
++++ b/include/linux/device.h
+@@ -510,8 +510,8 @@ ssize_t device_store_int(struct device *dev, struct device_attribute *attr,
+ struct dev_ext_attribute dev_attr_##_name = \
+ { __ATTR(_name, _mode, device_show_ulong, device_store_ulong), &(_var) }
+
+-extern int __must_check device_create_file(struct device *device,
+- const struct device_attribute *entry);
++extern int device_create_file(struct device *device,
++ const struct device_attribute *entry);
+ extern void device_remove_file(struct device *dev,
+ const struct device_attribute *attr);
+ extern int __must_check device_create_bin_file(struct device *dev,
diff --git a/debian/patches/series b/debian/patches/series
index 30b5cf1a040d..d3889f1327ad 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -346,6 +346,7 @@ features/all/cpu-devices/intel_idle-Revert-change-of-auto_demotion_disable_fl.pa
features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.patch
features/all/cpu-devices/cpufreq-gx-Fix-the-compile-error.patch
features/all/cpu-devices/tracing-mm-Move-include-of-trace-events-kmem.h-out-o.patch
+features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch
features/arm/kirkwood-add-dreamplug-fdt-support.patch
features/arm/kirkwood-fdt-convert-uart0-to-devicetree.patch