aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2014-08-27 23:24:58 +0000
committerBen Hutchings <benh@debian.org>2014-08-27 23:24:58 +0000
commitbc902f45203d43781282b0ae192008ac9fc13f45 (patch)
treed2d68f70370157e9b557116e43a4e228f47df14b
parentc692bc729db7886c2852285d5c29610fda007f65 (diff)
downloadkernel_replicant_linux-bc902f45203d43781282b0ae192008ac9fc13f45.tar.gz
kernel_replicant_linux-bc902f45203d43781282b0ae192008ac9fc13f45.tar.bz2
kernel_replicant_linux-bc902f45203d43781282b0ae192008ac9fc13f45.zip
[x86] mgag200: Enable auto-loading, but require mode-setting to be explicitly enabled
xserver-xorg-video-modesetting installs a modprobe config file to enable mode-setting in cirrusy and mgag200. Also update the description of the cirrus patch to reflect the current status. svn path=/dists/trunk/linux/; revision=21752
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/debian/cirrus-disable-modeset-by-default.patch8
-rw-r--r--debian/patches/debian/mgag200-disable-autoload.patch22
3 files changed, 17 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 88ab2f1012bb..65840fd99217 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,8 @@ linux (3.16.1-1) UNRELEASED; urgency=medium
* aio: fix reqs_available handling (regression in 3.14.10)
* mm: Enable FRONTSWAP, ZSWAP (except armel/{ixp4xx,orion5x})
(Closes: #725703)
+ * [x86] mgag200: Enable auto-loading, but require mode-setting to be
+ explicitly enabled (as xserver-xorg-video-modesetting does)
[ Vagrant Cascadian ]
* [armmp] Enable IMX_IPUV3_CORE (closes: #756810).
diff --git a/debian/patches/debian/cirrus-disable-modeset-by-default.patch b/debian/patches/debian/cirrus-disable-modeset-by-default.patch
index 35eee2bc654a..4036b4045536 100644
--- a/debian/patches/debian/cirrus-disable-modeset-by-default.patch
+++ b/debian/patches/debian/cirrus-disable-modeset-by-default.patch
@@ -2,10 +2,10 @@ From: Ben Hutchings <ben@decadent.org.uk>
Subject: cirrus: Disable by default
Forwarded: not-needed
-Current Debian userland is not compatible with this driver, so set
-modeset=0 by default (making module init fail).
-xserver-xorg-video-cirrus will need to override this once it is
-compatible, by installing a modprobe config file.
+This kernel driver is incompatible with older versions of
+xserver-xorg-video-cirrus, so do not enable it by default. It will be
+enabled by a modprobe configuration file installed by
+xserver-xorg-video-modesetting.
--- a/drivers/gpu/drm/cirrus/cirrus_drv.c
+++ b/drivers/gpu/drm/cirrus/cirrus_drv.c
diff --git a/debian/patches/debian/mgag200-disable-autoload.patch b/debian/patches/debian/mgag200-disable-autoload.patch
index 37d66f60cd49..cf023bcfeae0 100644
--- a/debian/patches/debian/mgag200-disable-autoload.patch
+++ b/debian/patches/debian/mgag200-disable-autoload.patch
@@ -4,18 +4,18 @@ Date: Mon, 24 Dec 2012 00:10:05 +0000
Forwarded: not-needed
This kernel driver is incompatible with older versions of
-xserver-xorg-video-mga, so do not autoload it yet. It will have to be
-loaded either by local configuration or as part of a package of a
-compatible X driver.
+xserver-xorg-video-mga, so do not enable it by default. It will be
+enabled by a modprobe configuration file installed by
+xserver-xorg-video-modesetting.
--- a/drivers/gpu/drm/mgag200/mgag200_drv.c
+++ b/drivers/gpu/drm/mgag200/mgag200_drv.c
-@@ -38,7 +38,7 @@ static DEFINE_PCI_DEVICE_TABLE(pciidlist
- {0,}
- };
+@@ -21,7 +21,7 @@
+ * which then performs further device association and calls our graphics init
+ * functions
+ */
+-int mgag200_modeset = -1;
++int mgag200_modeset = 0;
--MODULE_DEVICE_TABLE(pci, pciidlist);
-+/*MODULE_DEVICE_TABLE(pci, pciidlist);*/
-
- static void mgag200_kick_out_firmware_fb(struct pci_dev *pdev)
- {
+ MODULE_PARM_DESC(modeset, "Disable/Enable modesetting");
+ module_param_named(modeset, mgag200_modeset, int, 0400);