aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2011-12-22 00:05:05 +0000
committerBastian Blank <waldi@debian.org>2011-12-22 00:05:05 +0000
commit55a911975fade3d50ab2c76a74de9ad42e36f7c1 (patch)
treecebf6704935a6cf9a8d548862e55dad1b267f751
parent6d1ffd1fd5a1fa3ec6757c84a433d58314c71651 (diff)
downloadkernel_replicant_linux-55a911975fade3d50ab2c76a74de9ad42e36f7c1.tar.gz
kernel_replicant_linux-55a911975fade3d50ab2c76a74de9ad42e36f7c1.tar.bz2
kernel_replicant_linux-55a911975fade3d50ab2c76a74de9ad42e36f7c1.zip
* debian/changelog: Set version to 3.1.6-1.
* debian/patches: Remove merged patches. svn path=/dists/sid/linux-2.6/; revision=18404
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch89
-rw-r--r--debian/patches/bugfix/arm/nslu2-dma-size.patch40
-rw-r--r--debian/patches/features/all/staging-r8712u-Add-new-USB-ID.patch28
-rw-r--r--debian/patches/series/base3
5 files changed, 6 insertions, 165 deletions
diff --git a/debian/changelog b/debian/changelog
index f9536dceddba..c93ddf448b5c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,11 @@
-linux-2.6 (3.1.5-2) UNRELEASED; urgency=low
+linux-2.6 (3.1.6-1) UNRELEASED; urgency=low
+
+ * New upstream stable update:
+ http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1.6
+ - staging: r8712u: Add new USB ID (Closes: #651622)
+ - [arm] setup: initialize arm_dma_zone_size earlier (Closes: #651215)
[ Ben Hutchings ]
- * staging: r8712u: Add new USB ID (Closes: #651622)
* [x86] Enable HYPERV, HYPERV_STORAGE, HYPERV_NET, HYPERV_UTILS,
HYPERV_MOUSE as modules (Closes: #652014)
* cciss: Add IRQF_SHARED back in for the non-MSI(X) interrupt handler
@@ -12,9 +16,6 @@ linux-2.6 (3.1.5-2) UNRELEASED; urgency=low
- [x86] Include et131x (Closes: #651440)
- [x86] Include isci
- [ Arnaud Patard ]
- * [arm] setup: initialize arm_dma_zone_size earlier (Closes: #651215)
-
-- Ben Hutchings <ben@decadent.org.uk> Tue, 13 Dec 2011 05:50:44 +0000
linux-2.6 (3.1.5-1) unstable; urgency=low
diff --git a/debian/patches/bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch b/debian/patches/bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
deleted file mode 100644
index 8f9ebcb5836f..000000000000
--- a/debian/patches/bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From: Phillip Lougher <plougher@redhat.com>
-Date: Wed, 2 Nov 2011 13:38:01 -0700
-Subject: [PATCH] hfs: fix hfs_find_init() sb->ext_tree NULL ptr oops
-
-commit 434a964daa14b9db083ce20404a4a2add54d037a upstream.
-
-Clement Lecigne reports a filesystem which causes a kernel oops in
-hfs_find_init() trying to dereference sb->ext_tree which is NULL.
-
-This proves to be because the filesystem has a corrupted MDB extent
-record, where the extents file does not fit into the first three extents
-in the file record (the first blocks).
-
-In hfs_get_block() when looking up the blocks for the extent file
-(HFS_EXT_CNID), it fails the first blocks special case, and falls
-through to the extent code (which ultimately calls hfs_find_init())
-which is in the process of being initialised.
-
-Hfs avoids this scenario by always having the extents b-tree fitting
-into the first blocks (the extents B-tree can't have overflow extents).
-
-The fix is to check at mount time that the B-tree fits into first
-blocks, i.e. fail if HFS_I(inode)->alloc_blocks >=
-HFS_I(inode)->first_blocks
-
-Note, the existing commit 47f365eb57573 ("hfs: fix oops on mount with
-corrupted btree extent records") becomes subsumed into this as a special
-case, but only for the extents B-tree (HFS_EXT_CNID), it is perfectly
-acceptable for the catalog B-Tree file to grow beyond three extents,
-with the remaining extent descriptors in the extents overfow.
-
-This fixes CVE-2011-2203
-
-Reported-by: Clement LECIGNE <clement.lecigne@netasq.com>
-Signed-off-by: Phillip Lougher <plougher@redhat.com>
-Cc: Jeff Mahoney <jeffm@suse.com>
-Cc: Christoph Hellwig <hch@lst.de>
-Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
-Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
----
- fs/hfs/btree.c | 20 +++++++++++++++-----
- 1 files changed, 15 insertions(+), 5 deletions(-)
-
-diff --git a/fs/hfs/btree.c b/fs/hfs/btree.c
-index 3ebc437..1cbdeea 100644
---- a/fs/hfs/btree.c
-+++ b/fs/hfs/btree.c
-@@ -46,11 +46,26 @@ struct hfs_btree *hfs_btree_open(struct super_block *sb, u32 id, btree_keycmp ke
- case HFS_EXT_CNID:
- hfs_inode_read_fork(tree->inode, mdb->drXTExtRec, mdb->drXTFlSize,
- mdb->drXTFlSize, be32_to_cpu(mdb->drXTClpSiz));
-+ if (HFS_I(tree->inode)->alloc_blocks >
-+ HFS_I(tree->inode)->first_blocks) {
-+ printk(KERN_ERR "hfs: invalid btree extent records\n");
-+ unlock_new_inode(tree->inode);
-+ goto free_inode;
-+ }
-+
- tree->inode->i_mapping->a_ops = &hfs_btree_aops;
- break;
- case HFS_CAT_CNID:
- hfs_inode_read_fork(tree->inode, mdb->drCTExtRec, mdb->drCTFlSize,
- mdb->drCTFlSize, be32_to_cpu(mdb->drCTClpSiz));
-+
-+ if (!HFS_I(tree->inode)->first_blocks) {
-+ printk(KERN_ERR "hfs: invalid btree extent records "
-+ "(0 size).\n");
-+ unlock_new_inode(tree->inode);
-+ goto free_inode;
-+ }
-+
- tree->inode->i_mapping->a_ops = &hfs_btree_aops;
- break;
- default:
-@@ -59,11 +74,6 @@ struct hfs_btree *hfs_btree_open(struct super_block *sb, u32 id, btree_keycmp ke
- }
- unlock_new_inode(tree->inode);
-
-- if (!HFS_I(tree->inode)->first_blocks) {
-- printk(KERN_ERR "hfs: invalid btree extent records (0 size).\n");
-- goto free_inode;
-- }
--
- mapping = tree->inode->i_mapping;
- page = read_mapping_page(mapping, 0, NULL);
- if (IS_ERR(page))
---
-1.7.7.2
-
diff --git a/debian/patches/bugfix/arm/nslu2-dma-size.patch b/debian/patches/bugfix/arm/nslu2-dma-size.patch
deleted file mode 100644
index 4a9f6e3b6d2e..000000000000
--- a/debian/patches/bugfix/arm/nslu2-dma-size.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Queued as http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=7204%2F1
-
-arch/arm/kernel/setup.c: initialize arm_dma_zone_size earlier
-
-arm_dma_zone_size is used by arm_bootmem_free() which is called by
-paging_init(). Thus it needs to be set before calling it.
-
-Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
-Acked-by: Nicolas Pitre <nico@linaro.org>
-CC: stable@kernel.org
-Index: linux-2.6/arch/arm/kernel/setup.c
-===================================================================
---- linux-2.6.orig/arch/arm/kernel/setup.c 2011-12-11 17:48:29.000000000 +0100
-+++ linux-2.6/arch/arm/kernel/setup.c 2011-12-11 17:57:03.000000000 +0100
-@@ -904,6 +904,12 @@ void __init setup_arch(char **cmdline_p)
- machine_desc = mdesc;
- machine_name = mdesc->name;
-
-+#ifdef CONFIG_ZONE_DMA
-+ if (mdesc->dma_zone_size) {
-+ extern unsigned long arm_dma_zone_size;
-+ arm_dma_zone_size = mdesc->dma_zone_size;
-+ }
-+#endif
- if (mdesc->soft_reboot)
- reboot_setup("s");
-
-@@ -934,12 +940,6 @@ void __init setup_arch(char **cmdline_p)
-
- tcm_init();
-
--#ifdef CONFIG_ZONE_DMA
-- if (mdesc->dma_zone_size) {
-- extern unsigned long arm_dma_zone_size;
-- arm_dma_zone_size = mdesc->dma_zone_size;
-- }
--#endif
- #ifdef CONFIG_MULTI_IRQ_HANDLER
- handle_arch_irq = mdesc->handle_irq;
- #endif
diff --git a/debian/patches/features/all/staging-r8712u-Add-new-USB-ID.patch b/debian/patches/features/all/staging-r8712u-Add-new-USB-ID.patch
deleted file mode 100644
index dc1dceeae5f1..000000000000
--- a/debian/patches/features/all/staging-r8712u-Add-new-USB-ID.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From: Larry Finger <Larry.Finger@lwfinger.net>
-Subject: [PATCH V2] staging: r8712u: Add new USB ID
-Date: Sun, 11 Dec 2011 10:27:54 -0600
-Message-ID: <4ee4da0a.gJM5XfxwTWfv6h1X%Larry.Finger@lwfinger.net>
-Cc: devel@driverdev.osuosl.org, post@rolandgruber.de
-To: Greg Kroah-Hartman <gregkh@suse.de>
-
-Add USB ID for Sitecom WLA-2000 v1.001 WLAN.
-
-Reported-and-tested-by: Roland Gruber <post@rolandgruber.de>
-Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>
-Cc: Stable <stable@vger.kernel.org>
----
-
-V2 - fix typo in ID.
-
-Index: staging/drivers/staging/rtl8712/usb_intf.c
-===================================================================
---- staging.orig/drivers/staging/rtl8712/usb_intf.c
-+++ staging/drivers/staging/rtl8712/usb_intf.c
-@@ -89,6 +89,7 @@ static struct usb_device_id rtl871x_usb_
- {USB_DEVICE(0x0DF6, 0x0045)},
- {USB_DEVICE(0x0DF6, 0x0059)}, /* 11n mode disable */
- {USB_DEVICE(0x0DF6, 0x004B)},
-+ {USB_DEVICE(0x0DF6, 0x005D)},
- {USB_DEVICE(0x0DF6, 0x0063)},
- /* Sweex */
- {USB_DEVICE(0x177F, 0x0154)},
diff --git a/debian/patches/series/base b/debian/patches/series/base
index 19882c007b4f..397e941533a1 100644
--- a/debian/patches/series/base
+++ b/debian/patches/series/base
@@ -52,7 +52,6 @@
+ bugfix/all/CIFS-Fixup-trivial-checkpatch-warning.patch
+ bugfix/all/Fix-build-break-when-freezer-not-configured.patch
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch
-+ bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
+ features/x86/x86-Add-amilo-rfkill-driver-for-some-Fujitsu-Siemens.patch
+ bugfix/all/regulator_enable-nullpointer-dereference.patch
@@ -86,6 +85,4 @@
+ bugfix/all/0004-staging-brcm80211-restrict-register-access-method-fo.patch
+ bugfix/all/0005-staging-brcm80211-restrict-MIPS-dma-bug-workaround-t.patch
+ debian/inetpeer-hide-ABI-change-in-3.1.5.patch
-+ features/all/staging-r8712u-Add-new-USB-ID.patch
-+ bugfix/arm/nslu2-dma-size.patch
+ bugfix/all/cciss-Add-IRQF_SHARED-back-in-for-the-non-MSI-X-inte.patch