aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2010-12-12 14:55:10 +0000
committerBen Hutchings <benh@debian.org>2010-12-12 14:55:10 +0000
commitc4bd1958a9ba44fabb11804aa5c77c98c74fa9a7 (patch)
tree1fee79b35ae9ab18f50c3b5b883e4e2254e641ed
parent28e984657e458d223b5df72f26fb7d9e9893a9a2 (diff)
downloadkernel_replicant_linux-c4bd1958a9ba44fabb11804aa5c77c98c74fa9a7.tar.gz
kernel_replicant_linux-c4bd1958a9ba44fabb11804aa5c77c98c74fa9a7.tar.bz2
kernel_replicant_linux-c4bd1958a9ba44fabb11804aa5c77c98c74fa9a7.zip
[mips] Restore dma_cache_sync()
svn path=/dists/trunk/linux-2.6/; revision=16705
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/mips/mips-Restore-dma_cache_sync.patch42
-rw-r--r--debian/patches/series/1~experimental.41
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e327d4dbd063..099d8d660bc6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ linux-2.6 (2.6.37~rc5-1~experimental.4) UNRELEASED; urgency=low
* [powerpc,x86] Enable PATA_PCMCIA (Closes: #606324)
* Disable BLK_DEV_IDECS
* [alpha] Use libata-based drivers for most PATA controllers
+ * [mips] Restore dma_cache_sync() (fix yet another FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 11 Dec 2010 21:21:10 +0000
diff --git a/debian/patches/bugfix/mips/mips-Restore-dma_cache_sync.patch b/debian/patches/bugfix/mips/mips-Restore-dma_cache_sync.patch
new file mode 100644
index 000000000000..a1662c183c04
--- /dev/null
+++ b/debian/patches/bugfix/mips/mips-Restore-dma_cache_sync.patch
@@ -0,0 +1,42 @@
+From 3b4987bd33af91dd55325da395c236645b0aed16 Mon Sep 17 00:00:00 2001
+From: Ben Hutchings <ben@decadent.org.uk>
+Date: Sun, 12 Dec 2010 14:48:56 +0000
+Subject: [PATCH] mips: Restore dma_cache_sync()
+
+Commit 48e1fd5a81416a037f5a48120bf281102f2584e2 "MIPS: Convert DMA to
+use dma-mapping-common.h" renamed and un-exported this function.
+Since dma-mapping-common.h does not implement dma_cache_sync(), this
+was incorrect.
+
+Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+---
+ arch/mips/mm/dma-default.c | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/arch/mips/mm/dma-default.c b/arch/mips/mm/dma-default.c
+index 4fc1a0f..71d60c4 100644
+--- a/arch/mips/mm/dma-default.c
++++ b/arch/mips/mm/dma-default.c
+@@ -288,8 +288,8 @@ int mips_dma_supported(struct device *dev, u64 mask)
+ return plat_dma_supported(dev, mask);
+ }
+
+-void mips_dma_cache_sync(struct device *dev, void *vaddr, size_t size,
+- enum dma_data_direction direction)
++void dma_cache_sync(struct device *dev, void *vaddr, size_t size,
++ enum dma_data_direction direction)
+ {
+ BUG_ON(direction == DMA_NONE);
+
+@@ -298,6 +298,8 @@ void mips_dma_cache_sync(struct device *dev, void *vaddr, size_t size,
+ __dma_sync((unsigned long)vaddr, size, direction);
+ }
+
++EXPORT_SYMBOL(dma_cache_sync);
++
+ static struct dma_map_ops mips_default_dma_map_ops = {
+ .alloc_coherent = mips_dma_alloc_coherent,
+ .free_coherent = mips_dma_free_coherent,
+--
+1.7.2.3
+
diff --git a/debian/patches/series/1~experimental.4 b/debian/patches/series/1~experimental.4
new file mode 100644
index 000000000000..5ce9735e59bb
--- /dev/null
+++ b/debian/patches/series/1~experimental.4
@@ -0,0 +1 @@
++ bugfix/mips/mips-Restore-dma_cache_sync.patch