aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2010-02-04 21:08:38 +0000
committerBen Hutchings <benh@debian.org>2010-02-04 21:08:38 +0000
commitd80218483d712595d2bb08f2695be072f25e2cf6 (patch)
tree46cfb8f7e95456ca34bf1248429771ce6437574f
parent3e1c5d23281372b23b1a403e57887c3aa0aba1a0 (diff)
downloadkernel_replicant_linux-d80218483d712595d2bb08f2695be072f25e2cf6.tar.gz
kernel_replicant_linux-d80218483d712595d2bb08f2695be072f25e2cf6.tar.bz2
kernel_replicant_linux-d80218483d712595d2bb08f2695be072f25e2cf6.zip
Revert incorrect change to powerpc clocksource setup
svn path=/dists/trunk/linux-2.6/; revision=15122
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/clocksource-always-define-clocksource_max_deferment.patch20
-rw-r--r--debian/patches/series/82
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a2ba31ef2c0..503b21f7ee61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ linux-2.6 (2.6.32-8) UNRELEASED; urgency=low
[ Ben Hutchings ]
* Build lgs8gxx driver along with cxusb (Closes: #568414)
+ * Revert incorrect change to powerpc clocksource setup
-- Bastian Blank <waldi@debian.org> Thu, 04 Feb 2010 12:08:47 +0100
diff --git a/debian/patches/bugfix/all/clocksource-always-define-clocksource_max_deferment.patch b/debian/patches/bugfix/all/clocksource-always-define-clocksource_max_deferment.patch
new file mode 100644
index 000000000000..97e906bb7109
--- /dev/null
+++ b/debian/patches/bugfix/all/clocksource-always-define-clocksource_max_deferment.patch
@@ -0,0 +1,20 @@
+--- a/kernel/time/clocksource.c
++++ b/kernel/time/clocksource.c
+@@ -466,8 +466,6 @@ void clocksource_touch_watchdog(void)
+ clocksource_resume_watchdog();
+ }
+
+-#ifdef CONFIG_GENERIC_TIME
+-
+ /**
+ * clocksource_max_deferment - Returns max time the clocksource can be deferred
+ * @cs: Pointer to clocksource
+@@ -509,6 +507,8 @@ static u64 clocksource_max_deferment(struct clocksource *cs)
+ return max_nsecs - (max_nsecs >> 5);
+ }
+
++#ifdef CONFIG_GENERIC_TIME
++
+ /**
+ * clocksource_select - Select the best clocksource available
+ *
diff --git a/debian/patches/series/8 b/debian/patches/series/8
index 7b732e77cbf2..a2e53f425253 100644
--- a/debian/patches/series/8
+++ b/debian/patches/series/8
@@ -2,3 +2,5 @@
+ bugfix/powerpc/powerpc-tif_abi_pending-bit-removal.patch
+ bugfix/sparc/sparc-tif_abi_pending-bit-removal.patch
+ bugfix/all/cxusb-select-lgs8gxx.patch
+- bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch
++ bugfix/all/clocksource-always-define-clocksource_max_deferment.patch