aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Attems <maks@debian.org>2010-02-23 11:25:51 +0000
committerMaximilian Attems <maks@debian.org>2010-02-23 11:25:51 +0000
commit143e86173533ae22ec16d22c3b561338199918da (patch)
tree79d2b6dd7fb2ca1c1271f1bf9cdbf6dd8da0ab79
parent5098f104e3efce0ef06142fea0c4dff37836ba2f (diff)
downloadkernel_replicant_linux-143e86173533ae22ec16d22c3b561338199918da.tar.gz
kernel_replicant_linux-143e86173533ae22ec16d22c3b561338199918da.tar.bz2
kernel_replicant_linux-143e86173533ae22ec16d22c3b561338199918da.zip
add vgaarb followon patch
previous wasn't complete. svn path=/dists/sid/linux-2.6/; revision=15263
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/vgaarb-fix-target-default-passing.patch33
-rw-r--r--debian/patches/series/91
3 files changed, 35 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 544aaee82db9..b4cdd95fab2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,7 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* vgaarb: fix incorrect dereference of userspace pointer.
* Bump ABI to 3.
* drm/i915: give up on 8xx lid status.
+ * vgaarb: fix "target=default" passing.
[ Bastian Blank ]
* Restrict access to sensitive SysRq keys by default.
diff --git a/debian/patches/bugfix/all/vgaarb-fix-target-default-passing.patch b/debian/patches/bugfix/all/vgaarb-fix-target-default-passing.patch
new file mode 100644
index 000000000000..88c995650f16
--- /dev/null
+++ b/debian/patches/bugfix/all/vgaarb-fix-target-default-passing.patch
@@ -0,0 +1,33 @@
+From 2cc9116c2b37c525965d76a3e6def38913259427 Mon Sep 17 00:00:00 2001
+From: Kyle McMartin <kyle@redhat.com>
+Date: Tue, 16 Feb 2010 16:18:37 -0500
+Subject: [PATCH] vgaarb: fix "target=default" passing
+
+Commit 77c1ff3982c6b36961725dd19e872a1c07df7f3b fixed the userspace
+pointer dereference, but introduced another bug pointed out by Eugene Teo
+in RH bug #564264. Instead of comparing the point we were at in the string,
+we instead compared the beginning of the string to "default".
+
+Signed-off-by: Kyle McMartin <kyle@redhat.com>
+Reported-by: Eugene Teo <eteo@redhat.com>
+Signed-off-by: Dave Airlie <airlied@redhat.com>
+---
+ drivers/gpu/vga/vgaarb.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/drivers/gpu/vga/vgaarb.c b/drivers/gpu/vga/vgaarb.c
+index 24b56dc..2f6cf69 100644
+--- a/drivers/gpu/vga/vgaarb.c
++++ b/drivers/gpu/vga/vgaarb.c
+@@ -961,7 +961,7 @@ static ssize_t vga_arb_write(struct file *file, const char __user * buf,
+ remaining -= 7;
+ pr_devel("client 0x%p called 'target'\n", priv);
+ /* if target is default */
+- if (!strncmp(kbuf, "default", 7))
++ if (!strncmp(curr_pos, "default", 7))
+ pdev = pci_dev_get(vga_default_device());
+ else {
+ if (!vga_pci_str_to_vars(curr_pos, remaining,
+--
+1.6.6.1
+
diff --git a/debian/patches/series/9 b/debian/patches/series/9
index 28d904e93132..63105e1d9a81 100644
--- a/debian/patches/series/9
+++ b/debian/patches/series/9
@@ -21,3 +21,4 @@
+ bugfix/all/drm-i915-give-up-on-8xx-lid-status.patch
+ features/arm/openrd-base-uart.patch
+ features/arm/dns323-rev-a1-powerled.patch
++ bugfix/all/vgaarb-fix-target-default-passing.patch