aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2010-02-01 23:40:51 +0000
committerBen Hutchings <benh@debian.org>2010-02-01 23:40:51 +0000
commit74def3ddcea30bcede792269bb3616a64f2ef8c0 (patch)
tree4292dab5ecbfbaa04f2d692145e3a64583fd9543
parent7e0532181f811ffed58083b1e3e5cb56db13d80a (diff)
downloadkernel_replicant_linux-74def3ddcea30bcede792269bb3616a64f2ef8c0.tar.gz
kernel_replicant_linux-74def3ddcea30bcede792269bb3616a64f2ef8c0.tar.bz2
kernel_replicant_linux-74def3ddcea30bcede792269bb3616a64f2ef8c0.zip
clocksource/events: Fix fallout of generic code changes (Closes: #568030)
svn path=/dists/trunk/linux-2.6/; revision=15094
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch59
-rw-r--r--debian/patches/series/71
3 files changed, 62 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 187b10f30096..7733480762a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ linux-2.6 (2.6.32-7) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [sparc] ftrace: Fix build-time architecture detection (Closes: #568025)
+ * clocksource/events: Fix fallout of generic code changes
+ (Closes: #568030)
-- maximilian attems <maks@debian.org> Mon, 01 Feb 2010 17:16:31 +0100
diff --git a/debian/patches/bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch b/debian/patches/bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch
new file mode 100644
index 000000000000..05f21c1d9b18
--- /dev/null
+++ b/debian/patches/bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch
@@ -0,0 +1,59 @@
+From a362c638bdf052bf424bce7645d39b101090f6ba Mon Sep 17 00:00:00 2001
+From: Thomas Gleixner <tglx@linutronix.de>
+Date: Sat, 14 Nov 2009 00:26:34 +0100
+Subject: [PATCH] clocksource/events: Fix fallout of generic code changes
+
+powerpc grew a new warning due to the type change of clockevent->mult.
+
+The architectures which use parts of the generic time keeping
+infrastructure tripped over my wrong assumption that
+clocksource_register is only used when GENERIC_TIME=y.
+
+I should have looked and also I should have known better. These
+renitent Gaul villages are racking my nerves. Some serious deprecating
+is due.
+
+Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
+---
+ arch/powerpc/kernel/time.c | 2 +-
+ kernel/time/clocksource.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/arch/powerpc/kernel/time.c b/arch/powerpc/kernel/time.c
+index 92dc844..60ceb27 100644
+--- a/arch/powerpc/kernel/time.c
++++ b/arch/powerpc/kernel/time.c
+@@ -905,7 +905,7 @@ static void register_decrementer_clockevent(int cpu)
+ *dec = decrementer_clockevent;
+ dec->cpumask = cpumask_of(cpu);
+
+- printk(KERN_DEBUG "clockevent: %s mult[%lx] shift[%d] cpu[%d]\n",
++ printk(KERN_DEBUG "clockevent: %s mult[%x] shift[%d] cpu[%d]\n",
+ dec->name, dec->mult, dec->shift, cpu);
+
+ clockevents_register_device(dec);
+diff --git a/kernel/time/clocksource.c b/kernel/time/clocksource.c
+index b65b242..72a2dcb 100644
+--- a/kernel/time/clocksource.c
++++ b/kernel/time/clocksource.c
+@@ -466,8 +466,6 @@ void clocksource_touch_watchdog(void)
+ clocksource_resume_watchdog();
+ }
+
+-#ifdef CONFIG_GENERIC_TIME
+-
+ /**
+ * clocksource_max_deferment - Returns max time the clocksource can be deferred
+ * @cs: Pointer to clocksource
+@@ -509,6 +507,8 @@ static u64 clocksource_max_deferment(struct clocksource *cs)
+ return max_nsecs - (max_nsecs >> 5);
+ }
+
++#ifdef CONFIG_GENERIC_TIME
++
+ /**
+ * clocksource_select - Select the best clocksource available
+ *
+--
+1.6.6
+
diff --git a/debian/patches/series/7 b/debian/patches/series/7
index 31b92795cdde..39c28c5e8e71 100644
--- a/debian/patches/series/7
+++ b/debian/patches/series/7
@@ -1 +1,2 @@
+ bugfix/all/ftrace-Use-UTS_MACHINE-not-ARCH-and-word-size-in-recordmcount.patch
++ bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch