aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Attems <maks@debian.org>2010-01-26 16:48:48 +0000
committerMaximilian Attems <maks@debian.org>2010-01-26 16:48:48 +0000
commit5c7607248b0224d6a6c0079b372c737463818379 (patch)
treea4da7986993189a58ff7db2b2de3e2369107e2b3
parent16c2a4237a3b0902edd6eb0465f7ca41f62a8db4 (diff)
downloadkernel_replicant_linux-5c7607248b0224d6a6c0079b372c737463818379.tar.gz
kernel_replicant_linux-5c7607248b0224d6a6c0079b372c737463818379.tar.bz2
kernel_replicant_linux-5c7607248b0224d6a6c0079b372c737463818379.zip
Enable easier debugging of Power Managment code.
* topconfig set PM_DEBUG, PM_TRACE * unset PM_VERBOSE (dev option) * x86 set PM_TRACE_RTC and PM_TEST_SUSPEND svn path=/dists/trunk/linux-2.6/; revision=15009
-rw-r--r--debian/changelog1
-rw-r--r--debian/config/config4
-rw-r--r--debian/config/kernelarch-x86/config6
3 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 96c1efe44089..342fb373341e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -65,6 +65,7 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
[ maximilian attems ]
* [topconfig] set MEMORY_FAILURE, 9P_FSCACHE, INFINIBAND_IPOIB_CM
(closes: #565494)
+ * Enable easier debugging of Power Managment code. (closes: #478315)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 10 Jan 2010 17:38:50 +0000
diff --git a/debian/config/config b/debian/config/config
index d957c0d8ffee..2522a8466ab7 100644
--- a/debian/config/config
+++ b/debian/config/config
@@ -3212,7 +3212,9 @@ CONFIG_HZ_250=y
## file: kernel/power/Kconfig
##
CONFIG_PM=y
-# CONFIG_PM_DEBUG is not set
+CONFIG_PM_DEBUG=y
+# CONFIG_PM_VERBOSE is not set
+CONFIG_PM_TRACE=y
CONFIG_SUSPEND=y
CONFIG_HIBERNATION=y
CONFIG_PM_STD_PARTITION=""
diff --git a/debian/config/kernelarch-x86/config b/debian/config/kernelarch-x86/config
index 6f382fe093e6..33be3537f7b1 100644
--- a/debian/config/kernelarch-x86/config
+++ b/debian/config/kernelarch-x86/config
@@ -1297,6 +1297,12 @@ CONFIG_EFI_PARTITION=y
# CONFIG_MMIOTRACE is not set
##
+## file: drivers/power/Kconfig
+##
+CONFIG_PM_TRACE_RTC=y
+CONFIG_PM_TEST_SUSPEND=y
+
+##
## file: lib/Kconfig.debug
##
# CONFIG_DEBUG_SHIRQ is not set