aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2007-05-17 22:54:25 +0000
committerSteve Langasek <vorlon@debian.org>2007-05-17 22:54:25 +0000
commit6802c6e2344a4eb3e5b18e25c8c0bc91862e9d24 (patch)
tree2d628806eb3b14f9a68f7914d7e879bf59f82388
parent20e6ea9467de44cc87fc1471460c72c84d7de2eb (diff)
downloadkernel_replicant_linux-6802c6e2344a4eb3e5b18e25c8c0bc91862e9d24.tar.gz
kernel_replicant_linux-6802c6e2344a4eb3e5b18e25c8c0bc91862e9d24.tar.bz2
kernel_replicant_linux-6802c6e2344a4eb3e5b18e25c8c0bc91862e9d24.zip
[alpha] add isa_page_to_bus and isa_bus_to_virt defines to complement the
existing isa_virt_to_bus define; untested, but these should all be straightforward on alpha and defining them is certainly a better option for getting user feedback than disabling the affected drivers. svn path=/dists/trunk/linux-2.6/; revision=8599
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/features/alpha/isa-mapping-support.patch18
-rw-r--r--debian/patches/series/21
3 files changed, 28 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 3cbc2fd23028..d1e2be1544eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,17 @@
-linux-2.6 (2.6.21-2) unstable; urgency=low
+linux-2.6 (2.6.21-2) UNRELEASED; urgency=low
[ Christian T. Steigies ]
* m68k: fix atari scc patch
* m68k: install compressed vmlinuz images so the post-inst script can find it
- -- Christian T. Steigies <cts@debian.org> Thu, 17 May 2007 18:06:26 +0200
+ [ Steve Langasek ]
+ * [alpha] isa-mapping-support.patch: add isa_page_to_bus and
+ isa_bus_to_virt defines to complement the existing isa_virt_to_bus
+ define; untested, but these should all be straightforward on alpha and
+ defining them is certainly a better option for getting user feedback
+ than disabling the affected drivers.
+
+ -- Steve Langasek <vorlon@debian.org> Thu, 17 May 2007 15:53:31 -0700
linux-2.6 (2.6.21-1) unstable; urgency=low
diff --git a/debian/patches/features/alpha/isa-mapping-support.patch b/debian/patches/features/alpha/isa-mapping-support.patch
new file mode 100644
index 000000000000..7551c9ae1b7a
--- /dev/null
+++ b/debian/patches/features/alpha/isa-mapping-support.patch
@@ -0,0 +1,18 @@
+--- a/include/asm-alpha/io.h 2007-04-25 20:08:32.000000000 -0700
++++ b/include/asm-alpha/io.h 2007-05-16 19:01:44.000000000 -0700
+@@ -89,6 +89,7 @@
+ #endif
+
+ #define page_to_phys(page) page_to_pa(page)
++#define isa_page_to_bus page_to_phys
+
+ /* This depends on working iommu. */
+ #define BIO_VMERGE_BOUNDARY (alpha_mv.mv_pci_tbi ? PAGE_SIZE : 0)
+@@ -126,6 +127,7 @@
+ virt = phys_to_virt(address);
+ return (long)address <= 0 ? NULL : virt;
+ }
++#define isa_bus_to_virt bus_to_virt
+
+ /*
+ * There are different chipsets to interface the Alpha CPUs to the world.
diff --git a/debian/patches/series/2 b/debian/patches/series/2
new file mode 100644
index 000000000000..8d6645fbe154
--- /dev/null
+++ b/debian/patches/series/2
@@ -0,0 +1 @@
++ features/alpha/isa-mapping-support.patch